Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Sudden fatal error

edited March 2011 in Vanilla 2.0 - 2.8
I have not tried to upgrade to a newer version. Suddenly the forum started to spit out this error message:
Fatal error: require_once() [function.require]: Failed opening required '/home/foobar/public_html/forum/applications/controllers/class.controller.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/foobar/public_html/forum/library/core/class.dispatcher.php on line 529

Any ideas?


  • Only idea I have is to doublecheck the path to class.controller.php and see if there are any problems with the rights. I know you haven't changed anything, but you never know if there are some rights problems at the moment on your server.

    There was an error rendering this rich post.

  • mklmkl
    edited March 2011
    Thanks for your reply.
    Seems the /applications/controllers is missing. conversations, dashboard, skeleton and vanilla are the only folders present in /applications/.
    If I take a look in the latest version of Vanilla downloaded from here: I can't seem to find a "controllers" folder either. Am I missing something?
  • LincLinc Detroit Admin
    That path isn't supposed to exist, so no, you're not missing anything. The path should be /applications/core/library to get to class.controller.php.

    Possible problem with the dispatcher. @Tim?
  • TimTim Operations Vanilla Staff
    That is pretty strange. What version are you running there, @mkl ?

    Vanilla Forums COO [GitHub, Twitter,]

  • @Tim, I'm running 2.0.16 according to index.php. I've spoken to my hosting company and they claim they are not having any temporary problems with the server I'm on.
  • mklmkl
    edited March 2011
    require_once(CombinePaths(array(PATH_APPLICATIONS, $this->_ApplicationFolder, 'controllers', 'class.'.strtolower($this->_ApplicationFolder).'controller.php'))); seems to be on line 529 inclass.dispatcher.php.
  • TimTim Operations Vanilla Staff
    Yeah. Thats some dirty dirty tomfoolery. We've taken that crap out in our current version. I'm not sure what else to tell you. Does this happen on a page that should normally work?

    Have you tried deleting all your *.ini files in cache/ ?

    Vanilla Forums COO [GitHub, Twitter,]

  • @Tim, thank you! Deleted the .ini files in cache/ and now I'm able to view pages and log in.
    All pages were inaccessible before I did this. Perhaps I should try to update ASAP.
  • TimTim Operations Vanilla Staff
    If its working now, you can either upgrade or wait till the next version (which will be major). Your choice ;)

    Vanilla Forums COO [GitHub, Twitter,]

  • Had the same problem. Occurred when the username on the account was changed. Manually updated the database configuration settings but ended up with this error.

    Fix works like a charm. Thanks a lot!
Sign In or Register to comment.