Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla broken after upgrade?

I have been out of touch with trying to develop my forum for a while. I upgraded to Vanilla 2.0.17.9 following a harddrive repair. Now it is slowly dawning on me that my installation is corrupt or broken. Newly uploaded themes and add-ons installed and enabled were failing to show up on the dashboard and now a request to visit the site is met with a 'page not found' message.
? Have I done something seriously crazy? It'll be a shame to have to start from scratch again.

Comments

  • the details from the error log are:

    [29-Mar-2011 04:17:45] PHP Fatal error: Class 'VanillaModel' not found in /home/thenomad/public_html/studioblog/plugins/FileUpload/models/class.mediamodel.php on line 11
    and line 11 looks like this:

    class MediaModel extends VanillaModel {

    public function __construct() {
    parent::__construct('Media');
    }
    etc

    I'm a bit new to this seemingly utra-techie and hghly modular way of working so any advice would be helpful :-/
  • LincLinc Detroit Admin
    Try deleting the .ini files from your cache folder.
  • Thanks Lincoln. Have done this but there's no difference. Still displays 'page not found'.
  • edited March 2011
    from the source html of the error page i am seeing this
    body id="dashboard_home_filenotfound" class="Dashboard Home filenotfound "
    i don't know if that's helpful. if dashboard_home were an actual file(?) then my server can't find it either....
  • php running is version 5.2.13
  • edited March 2011
    this is becoming awesome. i read that tagging this: /?p=/utility/structure at the end of my fatally erroneous url might unblock something. it did. i got a sign-in page and then another 'page not found'. i hit the brouser's back-one-page button and everything then loaded up. but surely i hadn't actually done anything?
    which is true enough. i can access the dashboard but not the site.
    oddly, the application "Vanilla" was not enabled and trying to do so provoked this "Fatal error: Class 'CategoryModel' not found in /home/thenomad/public_html/studioblog/applications/vanilla/settings/structure.php on line 60"

    ?
  • lucluc ✭✭
    You could use this as well : /?p=/utility/update.
    When upgrading from a beta to 2.0.16, I had to run a few of those to fix it all.
  • cheers luc. i tried it. it was a "success" but didn't do anything. equally other utilities have worked but not been effective. it's an odd one but one thing is noticeable. i can force my way on to the dashboard but discussions, enabling Vanilla or visiting the site are all unavailable, as are theme changes for example. i can't nail where this tangle has come from. Perhaps my question should have been:
    "how can i rescue the membership data and discussions etc. so as to rebuild this from scratch?"
  • edited March 2011
    After a good night's sleep things seem to have changed but not improved. Is this about coding or nursing? Is it possible that some of the changes we might evoke take time to operate? Wow!
    Seriously. The server is insisting on fatality, a rogue line or an unknown infection perhaps. Anyone know what this means:

    if ($CategoryExists) {
    $CategoryModel = new CategoryModel();
    $CategoryModel->RebuildTree();
    unset($CategoryModel);
    it's line 60 of applications/vanilla/settings/structure.php and is the blockage according to the server's error log

    since Vanilla presumably can't run without its application and I can't enable it, it's just possible ,,,
    resuscitation or euthanasia ??
    there may be ethical considerations ,,,,
    :-))
  • edited March 2011
    ok. this is interesting. i have added
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    to the config/php file as recommended elsewhere and can now enable the Vanilla application.

    proceeding to take the patient's temperature ,,,,
  • i've just realised that nothing i have done over the last few days has made any difference. i can 'enable' Vanilla but it doesn't stick. out of options now. the patient is dying and the patience is exhausted
  • ps ,,, or pr (post requiem)

    i just did the following, playfully tweaking the corpse.

    from my limited dashboard in which i can no longer fully enable 'Vanilla', and cannot access discussions or change themes or make tea, i went to routes and created a 'discussions' link from my homepage, now nominated as categories.

    following the ethereal guidance at
    http://vanillaforums.org/docs/homepage#discussionslink
    quite randomly, as you do.

    believe it or not, this works. i have access at last to the discussions page at least.
    rigour mortice has not yet developed it seems ...
  • and finally. i have just tried to sign out and obtained a 'page not found'. as this forum is still 'live' on the internet anything is possible. i'm pulling it but am still very interested in exploring this further and getting back on line. one next step will be to try out a local host option and see what can be salvaged.
    more challenges to come and i expect to be chased to the horizon by apaches bearing different versions, extensions and plugins
    ah!
Sign In or Register to comment.