Please upgrade here. These earlier versions are no longer being updated and have security issues.

Emoticons work in preview but not in the post?

This discussion is related to the Emotify :) addon.
edited March 2013 in Vanilla 2.0 - 2.8
So as the title says I can create a post and put emoticons in which I can see in the preview. However when the post is submitted all I get is the actual text, like :) :(

I have edited the js file to add my own emoticons but only edited the emoticons lineup nothing else.

So why in preview but not displaying in the post?
Tagged:
«1

Comments

  • BUMP!

    Can anyone help here?
  • SheilaSheila ✭✭

    Hi!

    Installed Vanilla 2.0.18.4 recently (upgraded from Vanilla1) and I seem to have exactly the same problem. Emoticons work in preview but not in the post.

    I've edited the plugin code in order to get smileys show when somebody inserts for example :smile:

    Help would be appreciated!

  • peregrineperegrine MVP
    edited May 2012

    How can anyone help if you don't show the modifications to the code :).

    Use the buttonbar plugin and see if the emoticons work?

    if they do, then it may be an interaction with the plugin (if not buttonbar) you use to post messages.

    If they don't work, it may be an interaction with the format in which they are stored in the database.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • SheilaSheila ✭✭

    Sorry! :D

    Example of modification in .js ":bigsmile:": ["bigsmile"],

    Example of modification in .css .Emoticonbigsmile { background-image: url('images/bigsmile.gif'); }

    And they do show in preview, so I hope/assume this can't be totally wrong?

  • peregrineperegrine MVP
    edited May 2012

    unanswered - cleditor or buttonbar????

    impossible to tell without a frame of reference of the code changes.

    one random line could be placed anywhere in the code, and we can't guess where it is, actually we could guess, but the odds are the guess would be wrong.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • SheilaSheila ✭✭

    Here are all the plugins used:

    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    $Configuration['EnabledPlugins']['MFCDiscussionPagination'] = TRUE;
    $Configuration['EnabledPlugins']['AllViewed'] = TRUE;
    $Configuration['EnabledPlugins']['Quotes'] = TRUE;
    $Configuration['EnabledPlugins']['LikeThis'] = TRUE;
    $Configuration['EnabledPlugins']['Categories2Menu'] = TRUE;
    $Configuration['EnabledPlugins']['WhosOnline'] = TRUE;
    $Configuration['EnabledPlugins']['Signatures'] = TRUE;
    $Configuration['EnabledPlugins']['ShowDiscussionAuthor'] = TRUE;
    $Configuration['EnabledPlugins']['ButtonBar'] = TRUE;
    $Configuration['EnabledPlugins']['ApprovalEmailNotification'] = TRUE;
    $Configuration['EnabledPlugins']['TouchIcon'] = TRUE;
    $Configuration['EnabledPlugins']['LastEdited'] = TRUE;
    $Configuration['EnabledPlugins']['VanillaStats'] = TRUE;
    $Configuration['EnabledPlugins']['AuthorTimeView'] = TRUE;
    $Configuration['EnabledPlugins']['SplitMergeFE'] = TRUE;
    $Configuration['EnabledPlugins']['Emoticons'] = TRUE;
    $Configuration['EnabledPlugins']['Emotify'] = TRUE;

    There are both Emotify and Emoticons, since Emoticons -plugin seems to solve the problem with old, earlier smileys not showing in posts. My board is far from fresh installation, it used to run on Invision Board before Vanilla 1 and 2.

    Turning Emoticons-plugin off does not help with this problem so I guess there's no conflict between them two.

  • UnderDogUnderDog Moderator

    Sheila look in the database table of 'comments' and 'discussions', what is the value for the field 'Format'

    Sheila
  • SheilaSheila ✭✭

    Html in both

  • peregrineperegrine MVP
    edited May 2012

    Post a link to your site with an example emoticon that didn't work. I don't think its the database, I modified the field from markdown to html to text and it didn't matter the js is overriding anything there.

    what does the field in the body of the comment in the comment table look like does it have any escaped characters or does it show exactly what you entered.

    I see you have AuthorTimeView plugin enabled - Ha, one person using it :).

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • SheilaSheila ✭✭

    My site needs to have everybody to register. Should I make you test user -account? Would that be too much trouble for you?

    I tried to browse some recent comments via database, there's just so much data that didn't find the latest one's yet.

    AuthorTimeView plugin is great! :)

  • for the time being just create a test discussion add an emoticon that doesn't work and then add a comment with an emoticon that doesn't work and give a link to that discussion.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • SheilaSheila ✭✭
    edited May 2012

    Ok, I'm gonna make one public category. Will post link soon.

  • peregrineperegrine MVP
    edited May 2012

    the only suggestion I can give you.

    zip up your current emotify plugin directory. erase it and download the
    the vanilla version of emotify with the js in it.

    ":bigsmile:": ["bigsmile"],
    ":bagonhead:": ["bagonhead"],
    ":blahblah:": ["blahblah"],
    

    .....,
    ":wub:": ["wub"]

    modify the .css

    e.g.

    .Emoticonwub { background-image: url('images/wub.gif');  width: 20px; height: 20px; }
    

    modify the class.emotify.php

    ':wub' => 'wub',

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Sheila
  • SheilaSheila ✭✭

    Great, will do that!

  • Let us know if that works. Don't know where your emotify js code came from - maybe a previous version from vanilla one.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Sheila
  • SheilaSheila ✭✭

    I got the plugin version within Vanilla2 installation, I assume.

    Just to clarify, what used to be ":wub:": ["wub"], should be ':wub' => 'wub' ?
    And I edit in emotify.js since can't find any class.emotify.php within the plugin folder?

  • peregrineperegrine MVP
    edited May 2012

    my mistake emotify is already packaged in 2.18.04 - that is the version you want to use.
    It will have class.emotify.php. extract it again from the main vanilla, as you may have overwritten it when you downloaded emotify 1.0.

    /vanilla/plugins/Emotify/class.emotify.php

    should show emotify version in dashboard as 'Version' => '2.0.1',

    No need to modify the new js at all (a matter of fact, it is safer if you don't touch it. I added numerous emoticons that appeared in the dropdown box and appeared in the preview as well as the post.

    this was in your old js (transfer these to the emotify .css and class.emotify.php using the same technique in the emotify.css and class.emotify.php

    ":bigsmile:": ["bigsmile"],
    ":bagonhead:": ["bagonhead"],
    ":blahblah:": ["blahblah"],
    ":biggrin:": ["biggrin"],
    ":blush:": ["blush"],
    ":cry:": ["cry"],
    ":dazed:": ["dazed"],
    ":devil1:": ["devil1"],
    ":dooh:": ["dooh"],
    ":drool:": ["drool"],
    ":evil:": ["evil"],
    ":faint:": ["faint"],
    ":fork:": ["fork"],
    ":groovey:": ["groovey"],
    ":hahjust:": ["hahjust"],
    ":happy:": ["happy"],
    ":heart:": ["heart"],
    ":ihq:": ["ihq"],
    ":kettu:": ["kettu"],
    ":lol:": ["lol"],
    ":negotiate:": ["negotiate"],
    ":nope:": ["nope"],
    ":molping-around:": ["molping-around"],
    ":rofl:": ["rofl"],
    ":rok:": ["rok"],
    ":sneaky:": ["sneaky"],
    ":stunned:": ["stunned"],
    ":tongue:": ["tongue"],
    ":tuoppi:": ["tuoppi"],
    ":watis:": ["watis"],
    ":wink:": ["wink"],
    ":whaddado:": ["whaddado"],
    ":wub:": ["wub"] 
    

    and make the changes to the new .css and class.emotify.php - in the same manner as the other arrays show in those two files.

    I'm not sure why the emotify add-on is not updated or removed on the add-ons downloads (even though it is included in the distribution), makes things confusing.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Sheila
  • SheilaSheila ✭✭
    edited May 2012

    Now I have the right version. My Emotify seemed to be old version, I guess I've messed up somewhere along the way when uploading and installing plugins. Lame mistake.

    It's past midnight here, so it might be better for me to test it tomorrow in order not to mess up more. Gonna let you know, how it worked.

    Your support's been just super! Thank you so much :)

    UnderDog
  • peregrineperegrine MVP
    edited May 2012

    Sheila said:
    It's past midnight here,>

    mutta ei aurinko vielä paistaa siellä.

    Your support's been just super! Thank you so much :)

    Ei se mitään. Minun suomenkielen taitoni on huono. Täytyy harjoitella enemmän suomenkieltä ... Yksi, kaksi, kolme :)

    napsauta "kuin"-painiketta

    Mitä poro on päivälliseksi tänään

    :wink

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    SheilaUnderDog
  • SheilaSheila ✭✭

    Got the plugin working! Thank you so much once again. Wouldn't been able to figure it out by my self.
    One minor change thou, just in case anybody else has a need to show emoticons this way.

    ':wub' => 'wub', still has to have double dots on both sides like ':wub:' => 'wub', otherwise it will print an image and two dots beside the actual image on one side.

    peregrine said:
    mutta ei aurinko vielä paistaa siellä.

    Hahaha! One has to sleep thou, even when the sun doesn't go down much. And yes, those nightless nights are amazing.

    You're quite good with your suomi. ;)

Sign In or Register to comment.