HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

How can I activate this plugin?

This discussion is related to the nbbc addon.
dandvdandv New
edited March 2013 in Vanilla 2.0 - 2.8
I installed this plugin in Vanilla 2.0.17.10 stable, but it doesn't seem to parse BBcode:

http://64.62.228.109:5198/index.php?p=/discussion/2/test-bbcode

[b]bold text[/b] appears as entered, instead of displaying the bold text.

Is there some setting I need to change? The plugin page doesn't mention anything.

Best Answer

  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer
    Hmm, the plugin should have done this, but add the following to your config:
    $Configuration['Garden']['InputFormatter'] = 'BBCode';

Answers

  • ntuyelikntuyelik New
    edited June 2011
    same problem for me...It requires Vanilla version 2.0.2.a...
  • I assume that requirement means "2.0.2.a or later" and if the versioning scheme follows the usual conventions, 2.0.17.10 (the stable version) should satisfy the requirement.
  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer
    Hmm, the plugin should have done this, but add the following to your config:
    $Configuration['Garden']['InputFormatter'] = 'BBCode';
  • Thanks, adding that setting to config.php worked - new posts are formatted OK, though existing ones remain raw. Not a problem.
  • I added 'BBCode' to the config-defaults.php file and bbcode doesn't work. So then I added the entire line to config.php and bbcode doesn't work. Out of ideas. It is enabled. Help please!

  • LincLinc Detroit Admin
    edited December 2011

    First, never edit config-defaults.php. (Read the FIRST THING in that file!)

    Second, make sure $Configuration['Garden']['InputFormatter'] isn't already in your config.php somewhere. If so, remove the ones you added and change that one instead.

  • doesnt work for me...
    i checked if there was a $Configuration['Garden']['InputFormatter'] already in the config.php, found none, so i added $Configuration['Garden']['InputFormatter'] = 'BBCode'; and saved it, but it didnt change anything.
    i used [b]test[/b] for testing. old posts still look like [b]test[/b] without formatting and new ones dont either.

  • i just noticed something superstrange. the bbcode works...in signatures but not in posts O.o

  • Todd said:
    Hmm, the plugin should have done this, but add the following to your config:$Configuration['Garden']['InputFormatter'] = 'BBCode';

    that didn't work for me :(

  • K17K17 Français / French Paris, France ✭✭✭
    edited August 2014

    For me it works with ButtonBar, but Spoiler not work:
    If I disable NBBC, the spoiler code is not working:

    Test

    And if I enable it, the spoiler code is working, but the text is not in a spoiler

    Test

    But i want to have:

    Test

  • acidjackacidjack New
    edited January 2015

    hi everyone

    to enable BBCode for older comments and discussions you have to change value of 'Format' column from 'Html' to 'BBCode' in the DB (tables *_Comment and *_Discussion) for that comment/discussion

    after that when you'll try to edit comment/discussion you'll see message about BBCode under the editor

    but remember that old message is html-formatted so you have to fully rewrite it

Sign In or Register to comment.