Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Disable mobile version?

edited July 2011 in Vanilla 2.0 - 2.8
Hello all,

I know this may be an odd request but can you disable the mobile version? I have a vanilla forum embedded on my website and would prefer if the theme I had is used rather than switching to a mobile version.

I even deleted the mobile version from my themes folder but somehow it still changes themes even though I only have the one theme I want!

Any help = ) Thanks!
Tagged:

Comments

  • lucluc ✭✭
    Change this in config.php to the theme you would like to use.
    $Configuration['Garden']['MobileTheme'] = 'your_theme'

    On 2.0.18, you will also have a link to the full site available at the bottom. (you can check it on vf.org).

    As for being it embed, no idea what that will do to it all :).
    AzamNezam
  • thanks @luc, it worked for me :)
    I've disabled the mobile version until receiving any stable version...
  • How do I disable the mobile version on 2.1.8? I'm using the "bittersweet" theme, so I added this ...
    $Configuration['Garden']['MobileTheme'] = 'bittersweet' ... to the config.php file. No dice. Any help? Thanks!

  • @adrial79 Check if the value is not getting overriden at a later time in your config.php. If config values already exist, replace them.

    hgtonight
  • Well go figure. I tried it again and it worked! :) Thank you!

    hgtonight
  • I am also planning of removing mobile friendly theme and use responsive theme instead but about 40% of my organic visitors comes from mobile. Anyone experience drop in mobile traffic after changing your theme? thanks in advance.

  • I had the same question, but I'm using Bootstrap theme and it wasn't loading by default on mobile. I couldn't find that line you mentioned ($Configuration['Garden']['MobileTheme']), but after adding it, worked fine.

    Keep up!

Sign In or Register to comment.