Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] Discussion default last page

evolucjaevolucja New
edited November 2011 in Vanilla 2.0 - 2.8
Hello.
How to make that after opening a discussion it will display the last page not the first one?

Comments

  • ToddTodd Chief Product Officer Vanilla Staff
    Users that are signed in will automatically jump to the last unread comment. There is no specific feature to jump to the last page all the time.
  • Yes but if all comments are read then it will open first page.
  • UnderDogUnderDog Moderator
    edited September 2011
    @evolucja You can adjust it yourself in a template, if i'm not mistaking.
    In your template make a link with just a name:
    or
    Then in the link declaration when you see all your topics (discussions in a list)
    just do this:
    < a href = "url_to_my_topic#lastpost" >Title of the post< /a >
  • evolucjaevolucja New
    edited September 2011
    It went something wrong with your post. I don't see code ;)

    So do you mean that I have to change all urls like: http://klasaa.info/discussion/16/x-czy-ys change to http://klasaa.info/discussion/16/x-czy-ys/#lastpost?

    It doesn't work...
  • Users that are signed in will automatically jump to the last unread comment. There is no specific feature to jump to the last page all the time.
    how to do its (that registered users automatically jump to the last unread comment)? in 2.0.17.9 version.
    Now everybody register users must to scroll page down and go to the last page by himself to unread comments
  • before handling code, I recommend that you review the addons vanilla, there's one that lets you see the last post above, look for it you'll find it.

    sorry for my English ... I speak Spanish lol
  • I don't want to change order of comments. I want to default open last page
  • So how it is made on this forum?
  • LincLinc Director of Development Detroit Vanilla Staff
    @evolucja It is the default functionality for it to go to the last page if you've read all comments.
  • Well, i'm using 2.0.17.10 with old blue theme and it never redirects me to the last unread comment..
  • I'd like to chime in to say that this "default functionality" has never actually worked for me, even when logged in.

    So, no solution?
  • ToddTodd Chief Product Officer Vanilla Staff
    Have a look for the configuration setting:
    $Configuration['Vanilla']['Comments']['AutoOffset'] = TRUE;
    If you have a plugin that sorts the comments differently than the date inserted then auto offset will not work. I know the voting plugin is one plugin that changes this behavior.
  • edited November 2011
    Well that was an easy fix, I don't know why I haven't seen this solution before.

    Thanks.
Sign In or Register to comment.