Please upgrade here. These earlier versions are no longer being updated and have security issues.

Configuring conversations

JulesblJulesbl New
edited December 2011 in Vanilla 2.0 - 2.8

Hi

I am trying to fix an install of Vanilla 2, it has been upgraded from v0.9 via various versions of 1.0.

The main problem I am having is that the private conversations are not, apparently, available. There are no permissions associated in the roles and permissions section though there does seem to some configurations in config.php

// Conversations

$Configuration['Conversations']['Version'] = '2.0.17.10';

$Configuration['Conversations']['Installed'] = '1';

$Configuration['EnabledApplications']['Conversations'] = 'conversations';

Plus what is in the conversations config file.

Can anybody help?

Jules

Best Answer

  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer

    I recommend the following:

    1. Browser to /utility/update.
    2. If that doesn't work disable then re-enable conversations.

    Keep in mind that there aren't too many permissions associated with conversations. You should be able to browser to /messages/all though.

Answers

  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer

    I recommend the following:

    1. Browser to /utility/update.
    2. If that doesn't work disable then re-enable conversations.

    Keep in mind that there aren't too many permissions associated with conversations. You should be able to browser to /messages/all though.

  • Hi Todd

    Tried that, no effect.
    Getting this on /messages/all

    "Fatal error: Class 'ConversationsController' not found in C:\VSS\WS\Greenpower\web\forum\applications\conversations\controllers\class.messagescontroller.php on line 22"

    Seems like the system is not loading certain classes, had the same problem with class.dashboardcontroller.php till I put it in boostrap.php

    Jules

  • ToddTodd Chief Product Officer Vanilla Staff

    Is your site located in the path of the error message? If not your cache might be wrong.

    Try deleting /cache/*.ini. If you've moved the site recently then things won't be set properly.

  • LeftBrainLeftBrain ✭✭
    edited November 2013

    [Split Dammit] Bump this. Was there ever a fix? I'm having the same problem (using the Vanilla 2.0.18.8) I tried the suggestion of deleting the /cache/*.ini files but to no avail.

  • hgtonighthgtonight ∞ · New Moderator

    @LeftBrain did you recently update to 2.0.18.8?

    If the autoloader cache isn't out of date, try uploading a fresh copy of the core files.

    Make sure to take a backup first.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • That worked! Thanks.

  • For people who might be experiencing this problem in the future this is what I did to fix it.

    1. Download the latest Vanilla 2.0.18.8 file
    2. Unzip it to create the folder on your computer
    3. In your FTP software (I use Filezilla) open the unzipped vanilla folder and highlight all the folders & files.
    4. Drag that stuff to your forum folder.
    5. When you are asked the option to replace a file choose 'Overwrite if file is newer'

    That worked for me.

Sign In or Register to comment.