Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] My forum just went bonk : Server problem (corrupt DataBase)*

mashmash New
edited January 2012 in Vanilla 2.0 - 2.8

hello guys.
my forum has been bonked like for 5 hrs nw i actually thought it was a minor problem and it was gonna fix it's self, but till now i am still having the same problem and i didn't configure anything. The most intriguing part is that i can't also go to the back-end cos it's also bonked too.


the link to the forum is


  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    You need to access the Vanilla/conf folder on your webserver, and

    if you are using vanilla >= 2.0.18 Put

    $Configuration['Garden']['Debug'] = TRUE; `

    and if its < 2.0.18 put

    `$Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';`

    in your config.php file.

    This will give you a detailed error message, rather than the 'Bonk' one. Once you have that, either it will help you see what to do, or else you can post another question, asking specifically about the error.

  • Options

    Still same thing

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Still same thing

    What is?

    What did you do?

  • Options

    i added
    $Configuration['Garden']['Debug'] = TRUE;
    to the config.php file

    but i am still getting same thing.

  • Options

    $Configuration['Garden']['Debug'] = TRUE;

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Try adding the other line:

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    Even though I've got 2.0.18, I found it reported the full error.

  • Options

    i jus got the main error but i don't understand it at all..

    plz help me check it out and find out what the problem is

  • Options

    Well... luckily you figured out how to put the debug line in your config file.

    This time you have the following error:

    Incorrect information in file: './nairatio_vanil/GDN_Permission.frm'

    You can google for it and contact your host about it.

    I would also search in this forum for the exact term:
    Incorrect information in file You will never know if an exact match will pop up of a user that had the exact same problem last week.

    If you will post those silly little lines like:
    "Still same error", "It's not working", "done that", "It's not helping", "please help me"

    That will not work. It will be an easy close for this thread.

    There was an error rendering this rich post.

  • Options
    LincLinc Detroit Admin

    It looks like you have a database problem on your server. Try contacting your host and asking them to run a repair on the database you used for Vanilla.

  • Options

    you are not helping..
    Is it my fault the problem evovled?
    you putting it like i am dumb or something..

  • Options

    Thanks @Lincoln will do just that

This discussion has been closed.