Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Twitter logged in users cannot update their email

JulioRFAJulioRFA New
edited March 2012 in Vanilla 2.0 - 2.8

Hi guys, I´m having some issues with Vanilla (latest version).

My setup allows users to register/login with the Twitter plugin, and it works pretty good.

But once a user is logged-in (Member role without mods) cannot update their email, which defaults to Any advice or ideas?

Thank you.


Best Answer


  • Options
    ToddTodd Chief Product Officer Vanilla Staff

    You are not using the most recent version of Vanilla or the plugin. This has been fixed in the 2.0.18 branch.

  • Options

    Thanks Todd, In the index.php file says:

    define('APPLICATION_VERSION', '');

    Do you recommend to re-install Vanilla and see what happens?

  • Options
    edited March 2012

    Same thing here... I noticed this problem yesterday. I had the following versions:
    Vanilla Version
    Twitter plugin version 0.1a

    Now I have updated (following to:
    Vanilla Version
    (comes with Twitter plugin version 0.1a)

    And the problem remains. I registered here via twitter and the window that appeared asking for an e-mail and a username doesn't show on my forum.

    Thanks for your help.

    EDIT: typos ^^U

  • Options
    edited March 2012

    Solved with Twitter plugin 0.1b from the git repo :D

  • Options

    something you wish to keep your old plugins, but critical update are shipped with the core.

    If the plugin is not something you have modified, best to update.

    grep is your friend.

  • Options

    I don´t have a clue.

    I did what @Myddna. Updated to Vanilla and uploaded the Twitter plugin 0.1b.

    But I see no effect. Just as before, the "loading" gif keeps going and the info is not updated.

    Any ideas?

  • Options


    @JulioRFA did you try with a new twitter user? My "old" twitter users were unable to login after I installed Twitter plugin 0.1b, but with new ones everything went smoothly.

    I had to manually edit old twitter users using the Administration panel, assign them a valid email address and generate a new password. Lucky me, I had only two of them.

    Did you reconfigure the twitter keys in the new plugin? They disappear when you install it.

  • Options

    Yes I reinstalled & reconfigured.

    I tried with a new twitter user and the SignUp is working nice. Before the changes I didn't see the pop-up asking for Username and Email

    After logging in the user I went directly to the profile and then I tried to "update" the email... but no luck.

    Yesterday I was playing around with the Roles & Permissions and I noticed that if I give Administration rights to -edit- Users to the -member role- (yeah I know it sounds weird but...) they can update their own profile and the other members too as logic dictates.

    Maybe there is some trouble in permissions.

    I can play around the forum because there are no real numbers in users yet. I´m preparing it to receive members but I would like to be ready till then. I noticed the same problem with Facebook sign-up/signed-in users :/

    Thank you very much @Myddna for answering.

  • Options

    JulioRFA said:
    After logging in the user I went directly to the profile and then I tried to "update" the email... but no luck.

    You are right, I didn't notice the "save" button does not work when editing own account information :S. That's weird...

  • Options

    why wasn't the new version of the twitter signin plugin in the .4 release?

  • Options

    I´m wondering the same.

    Ok here it goes...

    Vanilla is a great concept but it simply don´t deliver the value I expected. I've installed 2 vanilla forums on different domains and I often get a lot of BONKS!...

    I don´t know but I really feel Vanilla Inc. is selling me the hosted version (by force)... I could give it a shot sincerely but the open source version don´t provide me some good validation to go for it.

    Maybe this is only happening to me and my servers are misconfigured or malfunctioning or whatever. I think Vanilla could defeat the true option out there - the vB guys - by giving more value in & on his product/service without hassles out of the box.

    *Note: English is not my primary language ;)

  • Options

    Why is this marked as [SOLVED]?

    I read the whole thread and I don't see a solution. I have the same problem with the Twitter login plugin 0.1a (on Vanilla Users are logged in automatically after hitting "Authorize" and cannot edit their custom generated "" emails after that. I tried getting 0.1b from GitHub and when I replaced 0.1a, Vanilla doesn't even recognize the new plugin and does not list it any more in Plugins.

    Any ideas if this can be solved at all (as far as I can see, it's been more than a year since this issue was reported)?

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @smartmenus said:
    I tried getting 0.1b from GitHub and when I replaced 0.1a, Vanilla doesn't even recognize the new plugin and does not list it any more in Plugins.

    This sounds like an installation issue. Please double check your plugin folder structure and report back.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.