HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Issue with latest version - Fatal error

Hi,

I installed the latest version (2.1a33), and see the following error when loading pages:

Fatal error: Wrong parameters for Exception([string $exception [,long $code ]]) in /var/www/.../library/core/class.userexception.php on line 23.

It's my understanding that this is related to older PHP versions (<5.3), but the stated Vanilla requirements are for 5.2. Can anyone help?

jim

Best Answer

Answers

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    Are you running PHP v5.2? If so, I'm pretty positive that Vanilla won't run on PHP < v5.3.

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

  • I am running php 5.2. I guess it's time for the Vanilla team to update their documentation to say PHP 5.3 is a requirement, not 5.2.

  • since when were those requirements for pre beta?

    documentation is for the stable version.

    grep is your friend.

  • So when I install a version of Vanilla and the readme.html packaged with that version tells me that the minimum PHP required is 5.2, I'm supposed to ignore that because it's not a release version?

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    The readme.html was last updated two years ago so quite frankly yes.

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

Sign In or Register to comment.