Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Version 2.1a33 - can't post replies?

I could be missing something fundamental here - I'm new to Vanilla - but I've just installed a fresh version of Vanilla from the GitHub master branch, default everything. Posting a new discussion works fine, but posting a comment/reply I see some really weird behaviour - I click "Post Comment" but the AJAX page update that comes back is the listing of the thread (as in just the title, number of views, number of comments - still zero).

This is happening in both FF and Chrome. You can see the installation at http://forums.devfusion.com/ . Any ideas what I've broken?! Thanks

Comments

  • Options

    I'd give 2.0.18.4 a try and see if it is a result of alpha or your setup.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Same problem here o/

    I use Version 2.1a33 too and get the same issue.

  • Options

    2.0.18.4 works fine - it just seems to be the alpha, but that's the version running on the hosted installation, right? Was expecting a few bits rough around the edges but not being able to post a comment seems fairly major...

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited December 2012

    I've been having that issue consistently with most of the 2.1 versions I've tried.

    Clearly most users don't experience this, so I figured it was something to do with my setup.

    Is it because 2.1 only work with PHP 5.3?

  • Options

    i experienced the same issue, this only occurs on localhost installed vanilla, if it's installed to your webserver it's fine.

  • Options
    ToddTodd Chief Product Officer Vanilla Staff

    Can I get some clarification on this issue? Do you not see a comment box? Can you open up your network panel and see if there is an error when you post? Stuff like that.

  • Options
    jone68jone68 New
    edited December 2012

    @Todd I can see the comment box. But the comment doesn't post. I may give the error out put of network panel but i'm not sure how can i open the network panel? from my browser or vanilla dashboard? didn't see that on dashboard.

  • Options
    peregrineperegrine MVP
    edited December 2012

    @achu
    if I understand you correctly.
    use google chrome - web developer tools. click network from the tools.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    LincLinc Detroit Admin

    If someone wants to PM me an admin login to a site with this problem on 2.1a33 I'd be happy to have a look. I can't register on @jamescrowley's site because reCAPTCHA isn't set up.

  • Options

    @lincoln will do

  • Options
    LincLinc Detroit Admin

    What's Garden.RewriteUrls set to in your config.php (if it's in there)?

  • Options
    LincLinc Detroit Admin
    edited December 2012

    Anticipating your reply is 'FALSE' or "Isn't in there", I believe we've found a fairly large bug: https://github.com/vanillaforums/Garden/issues/1496

    Workaround is to manually set it to "TRUE" for now and see if that works.

  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    via Email
    Or there is no foot asset?
  • Options
    LincLinc Detroit Admin
    edited December 2012

    @Todd said:
    Or there is no foot asset?

    It's there. It's an all-default installation so far. I also checked the source code for the definitions.

    My off-the-cuff guess is our grab-the-form-action ajax mechanism stopped bringing parameters along.

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited December 2012

    @Lincoln

    I can confirm that setting

    Garden.RewriteUrls from FALSE to TRUE sorted the problem on my local testing server.

  • Options
    jone68jone68 New
    edited December 2012

    Yes, I can confirm that too. It works that way.

  • Options
    LincLinc Detroit Admin

    Sweet. If it works that way, you should really have it turned on anyway so it's a good thing to discover if it's off. We try to auto-detect and enable it automatically during install, but it's not foolproof.

    That said, still definitely a compatibility bug for people who have a server that can't do our fancy URL rewrites.

  • Options

    Same here, that did the trick. I'm running under IIS rather than Apache - I presume that could impact the auto-detection story.

Sign In or Register to comment.