Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Porter 1.7 vs vBulletin 3.8.6 = no cake

acwderacwder New
edited December 2012 in Vanilla 2.0 - 2.8


I am currently looking for a alternative to vBulletin cause we'd like to move to something more open.

I found Vanilla which seems quite nice, especially for us since our main site is a WPMS (and bbPress is a bit to basic).

The problems started when I tried to use the porter.

  1. There is a missing , in the sql syntax which gave a nice warning, I'll add that on github later.
  2. The export doesn't seem to add any import tables that the importer in Vanilla wants. I get the following error:

Your database does not contain any import tables.

Searching for it here gave 0 results. Googling it only found the source code on github which when I looked into it has the following:

$TableNames = $this->SQL->FetchTables(':_z%');

  if (count($TableNames) == 0) {
     throw new Gdn_UserException('Your database does not contain any import tables.');

That means that it's searching through the export file for stuff named _zWildcard and adds them as table names. Only issue is that the exporter doesn't add any during a vBulletin export. It only specified things like : Table: Users and then lists all users etc.

What I've done on the vBulletin installation to try and find any issues on that side is to disable and uninstall all plugins and products, I've cleared out more then half the forum and ~20k users to bring down the size a bit (It's still big tho).

Any suggestions?


  • LincLinc Detroit Admin

    Are you selecting "Generate SQL only"? I've had problems with that and avoid it.

    Are you getting these issues while using the Porter file, or while importing the resulting file to Vanilla?

  • I've tried both with and without the "Generate import SQL only" option checked.

    1. Was with the porter file. The rest is while trying to import the resulting file but I think the fault of the import failing is the porter file.
  • acwderacwder New
    edited December 2012

    I think the issue I had with the importer can be ignored. Apparently putting the file in the folder uploads/import when it was to big to upload was incorrect tho it seemed quite logic. Now the import seems to have worked, need to verify it tomorrow. The porter tho still needs a little fixing but that was just a "," needed.


    Actually no it didn't work at all. The forum is a swedish one which means it has a lot of å ä ö. Somewhere along the process it ended the titles, content etc whenever one of those letter showed up.

Sign In or Register to comment.