Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6.1 is here with critical security patches. One of them has been publicly disclosed.

Can not set default localisation

Hello,
I am opening this topic as I was unable to solve my problem by reading previous entries about it.
As I need a German localisation for a small IT trainee class I tried to set up the most recent German localization pack. While enabling it went smoothly, the dropdown box for changing the default localisation pack remains empty.

Installation: Most recent Vanilla 2 Forums application on rented PHP 5.2.1 server

Attempted Solutions: Re-Installation of forum software + localization pack;
CHMOD permissions changed to 666/777 where required according to documentation;
Manual adaption of '$Locales = array_unique($Locales/*, SORT_STRING*/);' in class.localemodel.php

Help ressources used: Vanilla documentation,
http://vanillaforums.org/discussion/16162/my-default-locale-dropdown-selection-does-not-work
http://vanillaforums.org/discussion/15585/unable-to-set-a-default-locale-dropdown-list-is-void

Thank you for your help in advance!

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    @RobertW

    Installation: Most recent Vanilla 2 Forums application on rented PHP 5.2.1 server

    you may need the latest PHP version,It should be version 5.2.9 or newer.

    http://php.net/downloads.php

  • Thank you for your reply. As it is a rented server I have no influence on the PHP version used and need a software-side (as in forum) workaround for displaying the default locales.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    @RobertW

    Traurig, Maybe you could talk to your host and tell them their php is outdated .

    Did you check your config.php?see if you don't have this but for your locale? :
    $Configuration['Garden']['Locale']= 'en-CA';

    if you don't have this add it to your config.php see if it helps

  • I added the variable and replaced the config file on server, unfortunately without effect. Would changing "en-CA" to "de-DE" help which is the shortcut of the new localisation?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    Yes ! it certainly should en-Ca is english (Canada lol) so change to your locale de-DE (deutsch)

  • Still no change I'm afraid. Attaching my config file, if you could please check for possible mistakes...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    Your attachment did not show, Try erasing the old locale map ini

    /forum/cache/locale_map.ini

  • AnonymooseAnonymoose ✭✭
    edited January 2013

    @RobertW said:
    Thank you for your reply. As it is a rented server I have no influence on the PHP version used and need a software-side (as in forum) workaround for displaying the default locales.

    Change your server.

  • Apparently the file type is disallowed, not seeing any errors though. Tried erasing the locale map.ini, no effect.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    you can post the code using < pre > code goes here < / pre >

  • <?php if (!defined('APPLICATION')) exit();
    
    // Conversations
    $Configuration['Conversations']['Version'] = '2.0.18.4';
    
    // Database
    $Configuration['Database']['Name'] = '';
    $Configuration['Database']['Host'] = 'localhost';
    $Configuration['Database']['User'] = '';
    $Configuration['Database']['Password'] = '';
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    
    // EnabledLocales
    $Configuration['EnabledLocales']['german'] = 'de-DE';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['GettingStarted'] = 'GettingStarted';
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    
    // Garden
    $Configuration['Garden']['Title'] = 'IT 29 des BFW Vallendar';
    $Configuration['Garden']['Cookie']['Salt'] = 'R4VD4XM1DC';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = TRUE;
    $Configuration['Garden']['Email']['SupportName'] = 'IT 29 des BFW Vallendar';
    $Configuration['Garden']['Version'] = '2.0.18.4';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['InstallationID'] = 'EB91-B03D3B27-79B367C8';
    $Configuration['Garden']['InstallationSecret'] = '099e4eea39b3134f8d15f820ca927802c955af57';
    $Configuration['Garden']['EditContentTimeout'] = '-1';
    $Configuration['Garden']['Locale']= 'de-DE';
    
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    
    // Routes
    $Configuration['Routes']['DefaultController'] = 'discussions';
    
    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.0.18.4';
    $Configuration['Vanilla']['Discussions']['PerPage'] = '30';
    $Configuration['Vanilla']['Comments']['AutoRefresh'] = '5';
    $Configuration['Vanilla']['Comments']['PerPage'] = '50';
    $Configuration['Vanilla']['Archive']['Date'] = '';
    $Configuration['Vanilla']['Archive']['Exclude'] = FALSE;
    
    // Last edited 2013-01-26 12:31:44</pre>
    
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    Maybe it's nothing but could you try using capital letter ?

    $Configuration['EnabledLocales']['German'] = 'de-DE';

  • Tried and changed, no effect once more. Sorry, I know it's a pretty frustrating issue...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Well we know that the issue is likely outdated php on your server.

    I would back track and remove what you commented out and put it back to ($Locales, SORT_STRING);

    /forum/library/core/class.locale.php is what calls the active locales. It is what is supposed to render the definitions and also the settings in the dashboard.

  • RobertWRobertW New
    edited January 2013

    I know it's probably the php issue, however I consider it pretty annoying that changing the language fails because of a strangely coded dropdown-render-menu. I will probably need to switch to another forum software then but it's hard to find alternatives with simple structures like this. Came here as I didn't want another "complex" forum with category display and far too much functionality for my needs.

    Thanks for your assistance, I greatly appreciate it. :)

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    If the other forum software requires a newer php version you may have the same issues. All forum software uses php . I have not found any other forum software that is as user friendly as Vanilla. There are many German users here. Maybe @HalfCat can be of more help than I in this matter.

  • RobertWRobertW New
    edited January 2013

    I don't think we have a communication issue here, your suggestions were very helpful. PHP in itself is no problem and I'm running several parallel domains with different forum or cms software, this problem is the first of that kind I ever had. E.g. using the recently released Wordpress 3.5 build provides no problems at all.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You have the forum embedded in Wordpress ? The reason I mentioned HalfCat is because he might have more experience with that locale. Or know other German users of that locale who may have experienced the same issue.

    Also in doing research on Locales I find that there are various for Germany and it may be important t write them like this :

    German - Germany de-DE

    as you can see there is also

    German - Liechtenstein de-LI

    The first de is German in general and the second DE means Germany

    So I deduce from this:

    $Configuration['EnabledLocales']['German - Germany'] = 'de-DE';

    But the problem here is that something is not being summoned so it renders in the dashboard setting in the drop down menu. You can name a locale anything as long as the file name matches. It is just a name it should not affect it unless the names are wrong.

  • No, the forum was supposed to run as standalone, own domain, database and server directory. I downloaded the German localisation from Vanilla's localisation section, German for Germany in 'du' variation.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2013

    I ran out of ideas :( I downloaded the locale to see what it contains and the instructions, seems rather simple, it should work. Out of curiosity, before you installed the locale, were you able to see the en-Ca skeleton in the dashboard?

  • To be honest, I never checked. Admin-CP-wise Vanilla really was one of the most simple-to-work-with forums I ever used, but that's no help if such an important feature fails to work. Thanks for all your efforts though. :)

  • businessdadbusinessdad Stealth contributor MVP

    @RobertW Unless there are specific restrictions in place that prevent it, I would also suggest to ask your hosting provider to upgrade PHP, it's not particularly difficult for a SysAdmin.

    Wordpress requires version 5.2.4, therefore it's almost a coincidence that it runs on 5.2.1. Also, PHP 5.2 is no longer supported, and PHP 5.3 has been out for over four years, and includes many improvements. In my opinion, it would be a pity to abandon Vanilla only because the Server setup is outdated.

    422
  • I kind of feel like an idiot right now as I contacted my host about php and he told me he was in fact running 5.3 for a long time and was wondering where I was getting 5.2.1 from. Turns out I accidently read the min. requirements of the admin CP instead of the actual software running on it. This is pretty embarassing...

  • businessdadbusinessdad Stealth contributor MVP

    That's a good news, now we know that the server is configured correctly. May I ask you what Vanilla version are you using, exactly, and which language pack have you downloaded? I can try reproducing the issue, and I would like to make sure I follow precisely the same steps. Thanks.

  • http://vanillaforums.org/download
    Developers Download, version 2.0.18.4

    http://vanillaforums.org/addon/vf_de_de-locale
    German locale

    Still quite embarassed about this, my apologies to both of you :(

  • x00x00 MVP
    edited January 2013

    keep the name of the folder as vf_de_DE

    then set

    $Configuration['EnabledLocales']['vf_de_DE'] = 'de-DE';

    and

    $Configuration['Garden']['Locale']= 'de-DE';

    you should change the name of the folder without changing the local info, and there is no point.

    don't change the folder permissions to 777. that is both wrong on requirement and sensibility, nothing is write. you can use 755.

    grep is your friend.

  • I only did that for ruling out problems, normally I don't leave any folders or files with permissions higher than required. As for the language pack, I couldn't wait for resolving the issue as my class needed that site and I'm using a Q&A forum now, but I will install vanilla on a private domain for further testing over the weekend and attempt to rename the config entries as you suggested.

Sign In or Register to comment.