HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

ShareThis Plugin doesn't work with 2.1

This discussion is related to the ShareThis addon.

I have installed vanilla 2.1 and have been trying to make this plugin work. however, nothing shows up below the discussion. Can anyone please help?

Tagged:

Comments

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    You'll need to upgrade to ShareThis 1.1 if you'd like to use it with 2.1. You can find it here: https://github.com/vanillaforums/Addons

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

    manish29BBSForum
  • hey this works great. Thanks!

  • github update worked perfect for me, thank you.

  • Hi. I just updated to Vanilla 2.1 and Im using the Bittersweet theme. I just uploaded and enabled the ShareThis plugin 1.1 from Github here and the share icons arent showing up for me. I tried disabling all other plugins i had enabled and still nothing.

  • Just to update on this. I tested it on Chrome and Firefox, disabling all browser plugins and extensions, and I was unable to see the sharing icons on my Windows 8 laptop. I was using the latest version of Chrome and Firefox and even added exceptions in the advanced settings of my browsers but I still couldnt see them. Others using a Mac had no issue seeing them so there appears to be some kind OS/Browser configuration which doesnt allow the plugin sharethis icons to show in Windows 8.

  • One final add to this. The icons show on Windows 7 so this issue appears to be isolated to Windows 8. Ive updated GitHub and messaged ShareThis support on this as this is really the only social sharing plugin on Vanilla which has been updated recently and works correctly.

    https://github.com/vanillaforums/Addons/issues/81

  • LincLinc Detroit Admin

    I've uploaded the latest version.

    hgtonight
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes he tried mine too which was the latest version, this is an issue with windows 8 and has nothing to do with the plugin. According to the Share this forum. Other people have this issue. The plugin works and I can see it on my computer as well as the share this dev team. I saw it working in GMoney site and even liked a post to test it. So both plugins work.

    Mine adds the buttons in the comments too. I guess that is the only difference now.

  • Thanks for follow up. I reinstalled 1.2.1, which in my understanding would have been the same plugin I downloaded off GitHub over the weekend unless Im mistaken, and it now works on my Windows 8 machine, so im not sure what to say other than thanks.

  • Its strange as i clear my cache and reload the page. Sometimes it loads, sometimes it doesnt.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited May 2014

    you should get the CSS Reloader 1.1.2 extension for chrome and firefox, it reloads the style sheets freshly.

    https://chrome.google.com/webstore/detail/css-reloader/dnfpcpfijpdhabaoieccoclghgplmpbd

    https://addons.mozilla.org/es/firefox/addon/css-reloader/

    Also Clear Cache 0.3.5.1 works good

    I don't know if Linc also fixed it so it shows in the comments. Maybe that is what you don't see?

  • My apologies for the delayed reply here as I appreciate the help Vrijvlinder. I added the CSS Reloader and Clear Cache plugins for Chrome and Firefox on both my laptops (Windows 7 and Windows 8).

    The plugin icons still show fine in Windows 7 in both Chrome and Firefox but they do not for me in Windows 8. As you and others have indicated they show fine on Mac machines and Safari, and other Windows 7 / Vista laptops. Havent found another Windows 8 laptop to try on yet but will do soon.

    As they seem to show for the majority, I'm not as worried about this personally, but for feedback in case its helpful, this appears to either be an issue with the plugin display on Windows 8, or just my specific Windows 8 laptop, although ive literally tried disabling all other Vanilla and Browser extensions, including your most recent ones, and reinstalled the plugin, both your version and the Share This version, multiple times as well.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You also can't have a pop up blocker on either... You should look in the source and see if the browser is adding opacity:0 to the div or the images.

    I would try to add opacity:1; to the css of the buttons and see if that works.

    I know they worked on Windows 8 because I tested it on another computer I had.

Sign In or Register to comment.