Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

500 Server error

edited May 2006 in Vanilla 1.0 Help
I have enjoyed using vanilla 0.9.2 for a forum which I'm planning to enlarge, so I thought I'd have a look at the pre-release1.0. I took all the precautions of backing-up and so on, and tried the pre-release. Halfway through the upgrader, it throws a 500 server error. The error log seems just to show just permissions-type errors. No problem, I think, this is just nature's way of saying "Don't fix what ain't broke", I'll go back to my 0.9.2. Except that - on both a restore and a clean reinstall - I'm getting the server error. It's only when I attempt to access vanilla, the rest of my site is fine. What have I done to myself?


  • if there's a .htaccess file in your vanilla folder, look for anything weird in there.
  • MarkMark Vanilla Staff
    I love your icon, btw.
  • Nope. Just (one level up) in my root, and that hasn't been changed recently.
  • are you looking at the vanilla error log, or the web server error log?
  • edited May 2006
    @Mark: old link, can't remember where I found it ->

    @ithcy: The vanilla error log has a lot of
    [26-May-2006 14:32:31] PHP Warning: main(/home/xxxxxx/public_html/forum/appg/../conf/settings.php): failed to open stream: No such file or directory in /home/xxxxxx/public_html/forum/appg/settings.php on line 233
    where the files and directories do exist. I had changed the permissions as described in the upgrader.

    That wouldn't worry, if I was able to go back to .9.2. I'm really confused why it seems to be affecting only vanilla, even in a new install in a different directory.
  • I had a similar problem, only with a 403 error, with my upgrade when I changed the permissions to the mentioned folders in the upgrader to 666. When I changed them to 777, the upgrade worked fine. Maybe try what I did?
  • lechlech Chicagoland
    From the sound of it, I want to say that the existing 0.9.2.x database actually was upgraded to the 1.0 format. This is why making a backup of the database via phpMyAdmin or directly though mySQLdump is always important. Not sure if you did that or not, but it does sound like you have at least backed up your 0.9.2.x settings files, right? If you have backed up the 0.9.2.x version, delete the current contents of your forum directory and restore the 0.9.2.x version you were currently running. Make sure to restore permissions on the files and folders that need it within there. After doing so, things should be the way they were before the "upgrade". If what I suspect did happen, and the database tables were upgraded durring the 1.0 SVN/pre-release install, then your only choice is to move forward, and figure out what's going on as there isn't really a way to "roll back" safely to a previous version due to the DB changes. I would start doing a comparison on the configuration file from the old version against the new, excluding extensions/themes and everything else, just the basics to make sure things are in "working order" and then do everything else from within vanilla when you're able to finally access it.
  • MarkMark Vanilla Staff
    I want to say that the existing 0.9.2.x database actually was upgraded to the 1.0 format

    I don't think he made it that far. My guess is that it's permissions. He should try setting his permissions back to the way they were before the upgrade.
  • lechlech Chicagoland
    Well, if he didn't get that far, I'll say then he totally overlooked the readme /checklist file of necessary things to do before having at it :)
  • edited May 2006
    (Yeah, I have a mysql dump and my previous settings.)
    I was having permissions problems, and so had set everything neccessary to 777. In the upgrader, I got a 403 at first, and then after setting everything to 777, I got a 500 server error.

    What I can't understand, though, is why I'm having no luck with a completely clean 0.9.2 install, new db, new directory. Each time I try, I hit this problem. Nothing else on my site seems to be affected.

    pre-release -> [deleted]
    .9.2 -> [deleted]

    Thanks all for your help.
  • I think you'll find the 500 server error is due to the files having too many permissions and your apache setup not being willing to execute them from a safety point of view. I had that problem when i ran the installer but if i swapped the install files back to 666 (left the rest as 777) it worked fine. As for the 0.9.2. stuff i have no idea.
  • dunno if it's any help: On one provider I have to use (strato), the slightest use of mod_rewrite in an .htaccess file results in a 500 server error for the entire site.
  • you need to look at the web server error log.
  • lechlech Chicagoland
    Mini may be on the right path with apache then not allowing execution of files in a range of 777, bring everything down to 644, and only chmod folders which are necessary to 775 or 777 as necessary and bring files that need to get written to up to 666. Everything else that's not being written to should be 644 and folders at default should be 755. If that doesn't work, I have no idea what could possibly be going on.
  • Okay, that did it. I'm up and running again. Who knew that the machine gun approach wouldn't always work? *shrug* Thanks everyone
  • I must admit i was a little surprised myself. Glad you got it sorted though. I really aught to have posted that up when i had the problem myself.
  • lechlech Chicagoland
    And where were you, mini?! HUH?! WHERE WERE YOU!?
  • *drops to knees in tears and begs lech for forgiveness
  • lechlech Chicagoland
  • I'm having a similar problem, and no matter what combo i try it doesnt work. I either get a 500 error, a 503 error or simply a blank page when going to step 2...:(
This discussion has been closed.