Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

mobile theme does not work

Hi,

I just put together a forum www.vnforums.net & apparently the mobile theme does not work, I see the site on PC & ipad while both our android phones display "bonk something funny happened" curiously, my buddy's iphone does the same while both our ipads work just fine displaying the native vanilla theme though all three devices are running ios6 & my ipad often displays the mobile sites of commercial websites...

Does anyone out there has the same problem, is this a general problem on some server or is something fishy about my installation?
I'm hosted by netfirms & installed vanilla through netfirms' link to simplescripts.

Thx, Ben

Comments

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    @vnforums_net

    You need to create a Folder called Smarty and another called compile and put them in the cache folder .

  • Options

    @vrijvlinder said:
    vnforums_net

    You need to create a Folder called Smarty and another called compile and put them in the cache folder .

    Where & in order to do what? I never installed any theme, just used the theme that comes with vanilla natively.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    If you installed your forum app using simple scripts or something like that , these folders are missing and need to be created in order for the mobile themes to work.

    Just Create a folder, call it Smarty, then another folder called compile and put it in Smarty folder you just made, then put it in the cache folder of your installation.

    forum/cache

  • Options

    ok, @ my hosts site there is a "file manager" root>public_html>vanilla>cache>smarty>compile (empty)

    so the folders are there, I didn't have to put them in, are these the folders you're talking about?
    in root>public_html>cache there were no smarty/compile, I added them, still "bonk" on the phone :-(

    vrijvlinder, thx for your interest & help, keep it comin ;-)

  • Options

    Instead of guessing, do what the documentation says when you see bonk.

    and get the true error message.

    But you probably need 777 permissions on the folders. Or you could search for smarty compile.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    are these the folders you're talking about?

    yea that's them

    get the true error message.

    Switch on debugger or debug mode to get the full error message or ask your host to look or indicate where the error console is.

    the error I get is an internal misconfiguration server error message .

  • Options

    I found a cgi_error_log in the /stats folder:

    20130310T164630: vnforumsnet.netfirms.com/ss_2067929_ctga_install.php chmod: cannot access library/vendors/markdown/PHP': No such file or directory chmod: cannot accessMarkdown': No such file or directory chmod: cannot access Extra': No such file or directory chmod: cannot accessReadme.text': No such file or directory chmod: cannot access vanilla/library/vendors/markdown/PHP': No such file or directory chmod: cannot accessMarkdown': No such file or directory chmod: cannot access Extra': No such file or directory chmod: cannot accessReadme.text': No such file or di

    Does that tell you guys anything?

  • Options
    hgtonighthgtonight ∞ · New Moderator

    If those files do exist, you can try changing the permissions on those 3 files to 777 (read, write, and execute for user, group, and other).

    If they don't exist... I am not sure XD.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    @peregrine said:
    Instead of guessing, do what the documentation says when you see bonk.

    awe ! but, that would put my Crystal Ball OUT OF BUSINESS :(

    image

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    look in library /vendors/markdown to see if the file is there.... remember to change permissions on the file as well as the directory folder they are in..

  • Options
    peregrineperegrine MVP
    edited March 2013

    If you don't see the files in vendors - you should just do a clean new install of the source code. If you see the files change the permissions to make sure the web owner can read them.

    did you contact your host.

    clear your cache....

    remove the .ini files from cache

    and I think you read and should do this.... or you will be getting all kinds of guesses...

    http://vanillaforums.org/docs/errors

    and between what you have as well as the following

    I've not seen this with standard bonk errors...

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.