Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Image Upload on Mobile

On my android phone, If I view the website as a whole, I can upload images from my phone, but If I try to post a message using the mobile theme it doesn't show the "Attach a file" link on the page. Is there anyway that I can add the Attach a file to the mobile theme?

Also, can I change the allowable upload files to just image formats, and change the Attach a File text to Upload Image?

Thank you in advance

«1

Comments

  • Also, can I change the allowable upload files to just image formats, and change the Attach a File text to Upload Image?

    many repeat questions. did you try searching the forum either through google or by the forum and read the results before posting.

    you can make plugins "mobile friendly" - viewable on mobile views - this also has been discussed within the past week. try searching.

    as far as the plugin itself performing well in a mobile friendly environment - that is something you need to test when you make it mobile friendly - which means it will appear as an option (but might or might not work). Some plugin appear in a panel, so Obviously changing something to mobile friendly wont really help if the plugin deals with a panel since panels don't appear in mobile friendly just content.

    yes this was recently discussed - did you search the form or look at any messages over the past two weeks.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • yeah I did search, but all I found was irrelevant posts. can you supply me with links to the posts you are talking about

  • peregrineperegrine MVP
    edited March 2013

    if you searched and they were irrelevant, i probably can't help, because mine would be also.

    'MobileFriendly' => TRUE,

    search for file detect or maybe file upload or mobile friendly- see if you don't find anything that answers your question

    what search terms did you try?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I searched for mobile upload, and mobile file upload and didnt show anything besides people asking similar questions that I asked with no answer

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok look what you need to do is go into fileupload plugin and find the part that says

    'MobileFriendly'=>FALSE to 'MobileFriendly' = >TRUE

    However this does not guarantee that it will work, the mobile theme is very simple and it is not set up for fancy stuff, out of curiosity, if you go to full site on the mobile , can you upload after changing false to true ?

  • I can upload photos on my android phone right now, but I have to view the full site to do it. Its not listing the text "Upload File" on the mobile version. What file do I need to edit to get the text / link to show up on the mobile ? Thanks for your help

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Have you changed MobileFriendly to TRUE? Try that and see if the link appears, I will test it on my rig but Will be traveling so won't be on until I reach my destination. It may be possible to add an upload link if there in not one. But I must check it out first to be sure.

  • I really have no idea how to turn mobilefriendly to true. Where is it located at. Thanks

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    In your plugins folder , fileupload/class.fileupload.plugin.php

    
    // Define the plugin:
    $PluginInfo['FileUpload'] = array(
       'Description' => 'This plugin enables file uploads and attachments to discussions and comments.',
       'Version' => '1.5.2',
       'RequiredApplications' => array('Vanilla' => '2.0.9'),
       'RequiredTheme' => FALSE, 
       'RequiredPlugins' => FALSE,
       'HasLocale' => FALSE,
       'MobileFriendly' = >TRUE,
       'RegisterPermissions' => array('Plugins.Attachments.Upload.Allow','Plugins.Attachments.Download.Allow'),
       'SettingsUrl' => '/dashboard/plugin/fileupload',
       'SettingsPermission' => 'Garden.Settings.Manage',
       'Author' => "Tim Gunter",
       'AuthorEmail' => 'tim@vanillaforums.com',
       'AuthorUrl' => 'http://www.vanillaforums.com'
    );
    /**
    
    
  • hgtonighthgtonight ∞ · New Moderator
    edited March 2013

    @BrandonP You can put any configurations in your /conf/config.php file. Read through config-defaults.php to see what you can change. Do not modify config-defaults.php though. That file will list all the configuration options vanilla has by default.

    EDIT: Looks like it is time to log off, this is the second time I answered a question that wasn't asked!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • $PluginInfo['FileUpload'] = array( 'Description' => 'This plugin enables file uploads and attachments to discussions and comments.', 'Version' => '1.5.2', 'RequiredApplications' => array('Vanilla' => '2.0.9'), 'RequiredTheme' => FALSE, 'RequiredPlugins' => FALSE, 'HasLocale' => FALSE, 'RegisterPermissions' => array('Plugins.Attachments.Upload.Allow','Plugins.Attachments.Download.Allow'), 'SettingsUrl' => '/dashboard/plugin/fileupload', 'SettingsPermission' => 'Garden.Settings.Manage', 'Author' => "Tim Gunter", 'AuthorEmail' => 'tim@vanillaforums.com', 'AuthorUrl' => 'http://www.vanillaforums.com'

    This is what mine says, Can I just add MobileFriendly to it ?

  • Actually, that worked. I just had to add 'MobileFriendly' => TRUE, below 'HasLocale'. I just refreshed my mobile browser and it allows me to upload photos now. Perfect Thanks

  • hgtonighthgtonight ∞ · New Moderator
    edited March 2013

    Yes. Just like what @vrijvlinder suggested.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Right, well the way he worded it, he made it seem like the text MobileFriendly was already listed, which its not

  • hgtonighthgtonight ∞ · New Moderator

    @BrandonP sorry for the confusion. Be sure to mark your question as answered so other people with the same issue can quickly find the solution.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • how do i mark it as answered ?

  • hgtonighthgtonight ∞ · New Moderator

    When you hover over a post, different options appear. I don't remember the exact wording, but the original poster can choose posts as answers. You can also "react" to posts by hovering over them and clicking the buttons along the bottom of each post.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes I forgot to mention that that line is not in there by default you have to add it. Glad it worked :) You can just leave a reaction like awesome or insightful if you found it useful . Sometimes the mark the best answer link does not show up ...

  • After enabling "'MobileFriendly' => TRUE," it worked for me also but for some reason all my images uploaded, from an iPhone, are upside down. Is there a way to flip the image when uploading from mobile?

Sign In or Register to comment.