Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Liens vers les articles sur WordPress incorrects

edited March 2013 in Vanilla 2.0 - 2.8

FR :
Bonjour,
En premier, excusez-moi, je parle très mal anglais, je vais tanter de traduire via Google pour vous.

J'ai mon forum Vanilla intégré à WordPress, le soucis est que celui-ci ne donne pas les bons liens à WordPress et que donc, lorsqu'on clique sur un lien dans le widget des discussions récentes, celui-ci amène à une page 404 sur WordPress.
En effet, j'ai placé Vanilla dans le dossier du site Wordpress.

Comment faire pour corriger les liens ?
Il manque un index.php?p= dans les liens pour qu'ils soient correct.

Merci à vous.
Bonne soirée.

EN :
Hello,
First, excuse me, I speak very little English, I will translate via Google Tanter for you.

I built my Vanilla forum to WordPress, the concern is that it does not give the right links to WordPress and then, when you click on a link in the widget recent discussions, it leads to a page 404 of WordPress.
In fact, I put Vanilla in the site folder Wordpress.

How to fix the links?
It lacks a index.php?p= in the links so that they are correct.

Thank you.
Good evening.

Comments

  • Options

    What is the scenario?

    • wordpress -> /
    • forum -> /forum

    OR

    • forum -> /
    • wordpress -> /blog

    I'm guessing it is the first

    What I recommend is actually put wordpress in a folder. It is more organised, it can still act as root following these directions

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    so you have

    • /wordpress -> /
    • /forum -> /forum

    You will need to exclude the routing of the forum for wordpress

    (substitute the word forum for your folder)

    so change

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    
    # END WordPress

    to this

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^forum(/.*)?$
    RewriteRule . index.php [L]
    
    # END WordPress

    grep is your friend.

  • Options

    Hello,
    I have my WordPress Site in a folder named site and my Vanilla forum is in a subfolder of the site folder.

    WordPress -> /site
    Vanilla -> /site/forums

    I don't anderstand what I do with the script ?

    Thanks.

  • Options

    I have an other question.

    Why I have this in the URLs of my forum : http://www.iblogitech.fr/forums/index.php?p=/discussion/11/astuce-pour-iphoto#Item_5

    If I delete the ****index.php?p=****, the link of WordPress are correct.

    Is that possible to delete it ?

    Thanks. :)

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Are you familiar with htaccess file ? the code that is posted above would go in the file. Likely Wordpress also has one.

    so your root is (site) then in that you have WP but not in a subfolder? then you have Vanilla in a subfolder ?

    If you could post your htaccess file for both WP and Vanilla it would help to know how best to help you.

  • Options

    Thanks for your response.

    I have my WP site the folder web/site of my NAS.
    web is the root folder.
    And, Vanilla is in the folder web/site/forums folder.

    I have find the line in the config.php file :
    $Configuration['Garden']['RewriteUrls'] = FALSE;

    If I change FALSE to TRUE, the URL change and the index.php?p= isn't here.
    Good, but I have an 404 error too...

    For the htacces, i'm not familiar with this. :s

    Thanks.

  • Options
    x00x00 MVP
    edited March 2013

    yes you need to get your routing in order first.

    For the htacces, i'm not familiar with this. :s

    well you need it or other server rules for, the server to know what do.

    grep is your friend.

  • Options

    For the rooting,
    I have that :

    I'ts not correct ?

    With this routing, if I change to TRUE, it doesn't work.

    Thanks.

  • Options

    This will not help. You can't route your entire server from inside of vanilla.

    You need server rule that route the different apps you are using.

    grep is your friend.

  • Options
    edited March 2013

    Ok, with the htaccess ?

    I have change my htaccess but it doesin't work.

    My htaccess :

    BEGIN WordPress

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ - [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteCond %{REQUEST_URI} !^forums(/.*)?$

    RewriteRule . /index.php [L]

    END WordPress

  • Options

    what is your /forum/.httacces ?

    grep is your friend.

  • Options

    My forum htaccess :

    Original

    If you modify this file then change the above line to: # Modified

    RewriteEngine On

    # Certain hosts may require the following line.

    # If vanilla is in a subfolder then you need to specify it after the /.

    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)

    # RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    Thanks. :)

  • Options

    # RewriteBase /

    change to

    RewriteBase /forums

    grep is your friend.

  • Options
    edited March 2013

    I have change the # RewiteBase / to RewiteBase /forums and the config.php file and... I'TS WORKING FINE !

    A very very big thanks you !

    But, I have not change the htaccess of WordPress.

    Thanks ! :)

    Can you try if it working for you ?
    www.iblogitech.fr and click the link in the right sidebar named « Sur le forum ».

    Thanks. :)

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @LolYangccool

    If someone helped you, be sure to thank them by clicking awesome or insightful (these pop up along the bottom of posts when you hover over them). Also, mark the post with your answer as the best answer (will also pop up when you hover over a post). This will help other people with similar issues to quickly find a solution.

    Welcome to the community!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Ok, I have mark 2 posts. ;)

    How mark the topic like resolved ?

  • Options
    hgtonighthgtonight ∞ · New Moderator

    I believe marking an answer will mark it [Answered]. What say you @Underdog?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    edited March 2013

    I don't have the link resolved :

  • Options

    @Underdog manually changes the title if he decides to [Solved]

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    I think this was a discussion not a question, so you can't mark it.

    grep is your friend.

  • Options

    @peregrine said:
    Underdog manually changes the title if he decides to [Solved]

    True, I'm dreaming of a plugin, but for now, I'll do the manual labor. Maybe good plugin for rookie who wants to learn Vanilla programming :-)

    There was an error rendering this rich post.

Sign In or Register to comment.