Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Not Receiving Notifications

kirkpa31kirkpa31 ✭✭
edited April 2013 in Vanilla 2.0 - 2.2

Ok - members on my forum do not receive notifications when someone comments on their bookmarked discussion. However, when someone comments on MY bookmarked discussion, I get a notification. This is also the case with other things that generate notifications, such as the Peregrine Badges, only with this one even I do not get a notification.

This is not b/c of individual user preferences turned on/off in their profile, as these are test accounts - not real members.

I've run test after test, enabling and disabling relating plugins - all to no avail.

Any individual with experience or an idea please, please assist.

Comments

  • I think the only solution to this is to basically "reset" my forum

    Testing on another forum I've just developed and notifications all work fine - so I'll spend tomorrow recreating my forum one step at a time and hopefully this will reset and work.

  • I met the same problem, is not the latest version has this problem?

  • In further tests on my "test forum" this notification problem still persists.

    My observations on the test forum:

    1) All users receive notification when someone comments on their bookmarked discussion. -Works Fine.

    2) Only the administrator (me) receives a notification when someone comments on a discussion that I've started. Other users who start a discussion do not receive such notifications.

    I do not know what causes this, nor if it would be fixed with an upgrade.

  • I'm having the same problem. Did you ever get it worked out?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @kirkpa31 @Celeste

    Are you saying that user preferences are set to receive notification when someone comments on their discussion, but they don't receive such confirmation?

  • @whu606 Yes — as @kirkpa31 said, it seems to work for comments on bookmarked discussions (though the links are broken on mine) but nothing else that I can see. I'm an admin and I'm not even getting notifications for comments on discussions I've started as @kirkpa31 apparently is. I have everything checked off in the popup column in notification preferences. I also have a few checked off for email notification and haven't gotten any of those. The same seems to be the case for my co-admin as well as a test account (regular member).

  • hgtonighthgtonight ∞ · New Moderator

    can your server send email?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Actually, I did eventually get the email — it just took a little while. But, again, it was only for a comment on a bookmarked discussion. No emails for comments on discussions I started.

  • Same issue. Is there anyway to test the email is sending correctly from Vanilla? Some test function we can call manually?

  • To test if your email works put this code into an event fired by your plugin

    $Email = new Gdn_Email(); $Email->Subject("test email"); $Email->To("youremail@gmail.com"); $Email->Message("test message"); $Email->Send();

    hgtonight
Sign In or Register to comment.