Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Anyone want to hold my hand integrating Vanilla with my Wordpress site?

O.K., I think I give up--or at least need some help.

I'm trying to do two things--enable Single Sign on at my site and embed Vanilla in my Wordpress theme.

I've followed the instructions as best I can, googled my brains out, and experimented--I'm obviously missing something simple since this seems so easy for everyone else. Can't get either to work.

I would dearly appreciate anyone willing to walk me step by step through this...

For starters here is the main site: http://www.montarafog.com
Theme is Canvas by WooThemes.

and here is the forum: http://www.montarafog.com/vanilla

Any takers? :)

--Darin

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    What version of Vanilla are you running?

    What are the exact steps you took to embed the forums?

    I have never needed single sign on, so I can't help you with that. :(

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    DarinbDarinb New
    edited May 2013

    Hey hgtonight,

    Any help would be great. I'm running the current Wordpress and Vanilla 2.0.18.4.

    I have the Vanilla Forums plug in installed. jsconnect is installed on the Vanilla side. In the WP plug-in the Forum page is set to http://www.montarafog.com/discussions/ , widget integration is unchecked, and the Forum embed code points to http://www.montarafog.com/vanilla/js/embed.js

    I've double checked and that URL does point to the correct location for the embed.js file. The "discussion" page is blank. I both left the page blank (trusting the plug-in to do all the work) and I tried to cut/paste the script in directly. No luck.

    I also tried to use the script offered by Vanilla (which points to:
    http://www.montarafog.com/vanilla/plugins/embedvanilla/remote.js ) with no luck, pasting it into the page. Still blank. (That URL also points to an existing file.)

    Thanks,

    --Darin

    PS btw, how do I post a script in a way that it can be read but not acted on on this forum?

  • Options
    hgtonighthgtonight ∞ · New MVP

    Alright, first things first, you need to upgrade to 2.0.18.8 for security reasons.

    You need to enable the <Embed> Vanilla plugin in your Vanilla install.

    Copy the embed code from Dashboard->Addons->Embed Vanilla.

    Now that is done, in WP, you need to install and enable the Vanilla Forums plugin by Todd Burry.

    Then, still in WP, you need to validate your Vanilla install by going to Dashboard->Vanilla Forum->Setup. Put the url to your Vanilla install and make sure it validates.

    Now, you need to paste the embed code you copied earlier into Dashboard->Vanilla Forum->Forum Integration. I would also suggest you change the Forum Page in Wordpress to http://www.montrarafog.com/forums/... at least for now.

    Be sure to save your changes.

    Now you should see your Vanilla install at http://www.montrarafog.com/forums/.

    If you don't, after following these instructions, look at your network traffic for 404 errors.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    O.K., I'm going down your list--and I'm stuck on #1 :(

    I'm following these instructions: http://vanillaforums.org/docs/installation-upgrade

    But what does 2.1 mean when it says "Upload your new version of Vanilla 2"

    Surely not overwrite your plug in and theme folders? Perhaps we are just talking about the "vanilla" subfolder in the applications folder?

    --Darin

  • Options

    O.K, I found a better page: http://vanillaforums.org/discussion/12740/vanilla-2-upgrading-tips

    Instructions followed successfully--now at version 2.0.18.8

    I'm surprised the upgrade process is not automated...

    Embed-Vanilla plug in is enabled, script copied. WP Vanilla Forums by Burry installed an enabled. Install validates. Changed name to "forum," pasted script.

    Tried to go to the page--went to "Discussions" page instead. No "Forums" page created. (Is this something to do with earlier attempts and leftover files in the trash or elsewhere with the "Forums" name? Tried using "montarafogforums" but still go back to the same "Discussions" page. Tried random letters--still goes to Discussion page. Very odd.

    Not sure how to look at my network traffic...

    --Darin

  • Options
    hgtonighthgtonight ∞ · New MVP

    I can look at the network traffic from a client side.

    As far as the WP issue, I am not sure what you mean. Is your menu link not updated?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I get to the WP Forum integration area and I copy in the vanilla script. Then I change the "Forum Page in Wordpress" and save. When I go to that page I see a blank page with the title "Discussions"--even if I used "forums" or whatever. Discussions is a pre-existing blank page.

    Using another URL (like "forums" for the locations doesn't automatically create a new page. I also tried to manually create a new page to receive the forum. In this case I used "test1234" as the URL. I created a page called "test1234" and then looked at the page. It is still blank but strangely the URL changes to ".../test1234-2".

    --Darin

  • Options

    Still stuck! :)

    --Darin

  • Options
    hgtonighthgtonight ∞ · New MVP

    I am afraid I can't help you get any farther. :(

    I would suggest trying it with a fresh install of WP and Vanilla. If you can get it to work, you can use your customizations for reference to help in debugging it.

    Sorry :(

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.