HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Panel Box Toggles - Known plugin conflicts

This discussion is related to the Panel Box Toggles addon.
hgtonighthgtonight ∞ · New Moderator

Heya!

If you are running any plugins that add something to the panel, let me know so I can test for compatibility. :D

Search first

Check out the Documentation! We are always looking for new content and pull requests.

Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Comments

  • DenisSDenisS My brain hurts Buriram ✭✭

    I was using Hide panel but could not figure out how to hide "tagging panel" so i tried to install this and get this error: Is there a new verion of Vanilla?

    PanelBoxToggles is missing the following requirement(s): Vanilla 2.0.18.8.

    DavidShine
  • hgtonighthgtonight ∞ · New Moderator

    The latest stable version of Vanilla is 2.0.18.8.

    You should update for security reasons.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    TamaUnderDog
  • peregrineperegrine MVP
    edited June 2013

    @hgtonight

    nice plugin - finally tried it out.

    I like your plugin better than my hidepanel plugin. But if you use hidepanel plugin at the same time as Panel Box Toggles and expandable categories you can get some interesting dance routines. Kind of like clicking twice on the open button on a dvdplayer - it open but closes immediately before you can put the disk in :).

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonight
  • hgtonighthgtonight ∞ · New Moderator

    @peregrine I just tried yours out!

    What settings did you use get the interesting dance routines? I couldn't make it do it with HidePanels 1.4.3 and PanelToggles 1.1 on Vanilla 2.0.18.8.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • peregrineperegrine MVP
    edited June 2013

    What settings did you use get the interesting dance routines?

    there is no reason to use hidepanel with your plugin with these settings.

    But this is how to make them dance by clicking on one or the other open close of each respective plugin

    if you use hidepanel plugin at the same time as Panel Box Toggles and expandable categories you can get some interesting dance routines

    these are the configs for the hidepanel once it is enabled - to dance with the toggles.

    $Configuration['Plugins']['HidePanel']['Page1'] = '';
    $Configuration['Plugins']['HidePanel']['Page2'] = '';
    $Configuration['Plugins']['HidePanel']['Page3'] = '';
    $Configuration['Plugins']['HidePanel']['AllDisc'] = '1';
    $Configuration['Plugins']['HidePanel']['HideToggle'] = 'toggle';
    $Configuration['Plugins']['HidePanel']['AllCat'] = '1';
    $Configuration['Plugins']['HidePanel']['ShowCatPanel'] = 'both';
    $Configuration['Plugins']['HidePanel']['Page4'] = '';
    $Configuration['Plugins']['HidePanel']['Debug'] = FALSE;
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • By the way feel free to grab any code (good or bad :)) to restrict settings on pages in your plugin, if you so desire.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    @peregrine Thanks!

    I still couldn't get it to dance. :(

    Maybe my computer was just born a wallflower. ;D

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrineUnderDog
  • DenisSDenisS My brain hurts Buriram ✭✭

    It won't hide this in my panel>> Most Popular This Week

    DavidShine
  • hgtonighthgtonight ∞ · New Moderator
    edited August 2013

    @DenisS

    What version of Vanilla are you running?

    What addon creates the panel you are referring to?

    What plugins do you have enabled?

    What theme are you using?

    Assuming you are referring to this addon, I see no issue on 2.0.18.8 or 2.1b1 using the default themes.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDog
  • DenisSDenisS My brain hurts Buriram ✭✭
    edited August 2013

    Vanilla Ver 2.0.18.8
    The theme I'm using is. FB-Vanilla version 1.0 by Sabbatical.com
    The plugin that won't collapse is MostPopular 1.5 by By Peregrine
    I have 75 plugins enabled to many to list easily.
    It's not a great problem as it only list the last 5 most popular. Just thought you might want to know. Thanks it's help to tidy up the forum.

    DavidShine
  • hgtonighthgtonight ∞ · New Moderator

    @DenisS Would you mind upgrading MostPopular to 2.0 and letting me know if this still causes you issues?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDog
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @DenisS you don't need all those plugins, specially the Vanilla 1 plugins and also those that did not work for you. It is just dead wood .... If you remove them, do it from the file manager not the dashboard.

    UnderDog
  • DenisSDenisS My brain hurts Buriram ✭✭

    vrijvlinder most of the plugins i have i use, and they are enable and work, i have the version checker install which helps. I do remove the ones i don't use. Thanks for your help
    hgtonight you say "@DenisS Would you mind upgrading MostPopular to 2.0" maybe i might have a look as the upgrade from .4 to .8 went without a hitch.

    DavidShine
  • hgtonighthgtonight ∞ · New Moderator

    @DenisS I just tried Most Popular 1.5 on 2.0.18.8 and can confirm that its module contains invalid markup. This is fixed in Most Popular 2.0. Updating Most Popular to 2.0 will fix your issue.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • DenisSDenisS My brain hurts Buriram ✭✭

    Oh sorry misunderstood I thought you meat upgrade to vanilla 2! Ok got the lastest Most Popular and all ok now thanks.

    hgtonightUnderDogDavidShine
Sign In or Register to comment.