Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Simple Editor + Button Bar with Markdown / Strange issue with missing line breaks on 2.1b1?

When I write something in two line it gets reformated to one line, which is quite annoying. Example:

Writing something like:

Greetings,
MasterOne

gets reformated to

Greetings, MasterOne

I just checked, the very same issue is also present here on Vanilla Community Forum, so you can try for yourself (if you don't already know).

Is there a reason for this reformating, and can it be switched off somehow?

Comments

  • hgtonighthgtonight ∞ · New Moderator

    This is the default behavior of markdown. I have never messed with a formatter before.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • businessdadbusinessdad Stealth contributor MVP
    edited May 2013

    That's correct. Based on markdown specifications, if you wish to enter a new line, you have to add two spaces at the end of your line. That is:

    First line_space__space_Second line

    becomes the following

    First line
    Second line

    No need to change or disable anything, it's just a matter of getting used to it.

    Addendum
    If you are asking yourself something like "what if I really really really want to change such behaviour?", the answer is "you should really really really not do it." The reason is, simply, that markdown works that way. Users who know how to use it won't have difficulties, User who don't know it at all will have to learn it anyway. Changing the formatter would force your Users to learn a new "dialect" that only your website will use, and that could bring disturbance in the Force.

  • @businessdad

    Thanks for the explanation. Clearly my fault, as I didn't read up on Markdown, which I will do now. :)

Sign In or Register to comment.