Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Vanilla just plain doesn't work. Shows pages, but nothing will update

I can install it.
I can't make posts. I can't change themes. I can't activate plugins.

The ajax stuff just never finishes, and nothing changes in the DB.
I don't see how I'm supposed to debug this.

Best Answers

«1

Answers

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited May 2013

    @Sadako

    You don't say what version of Vanilla you are using.

    You don't say what kind of system you have installed it on.

    You don't give any real detail about what you have done.

    I don't see how we're supposed to help you.

  • Options

    well that is a GET not a POST

    if you can't activate plugins and theme that sounds like a file permissions issue.

    what version of vanilla are you using?

    grep is your friend.

  • Options

    It is a POST. I just added on the data it's sending.

    The version is the most recent, not beta, which is Version 2.0.18.8.
    It's on Debian 6.0.7 with Mysql 5.5.30-1~dotdeb.0 (Debian)

    All I did is install it, and try to use it.
    It was working before, and mysteriously stopped while I can't think of anything I've changed except for commenting out #bind-address on my.cnf to allow a remote mysql connection only from a single IP.
    But local connection is still allowed, and works, and it's the same connection that vanilla uses to the db. Plus, it seems to display things correctly, but nothing is changeable.
    I tried reinstalling(deleted all DB fields and uploaded Vanilla again, then ran the installer), and installing works and sets up the single admin user, but I can't post as admin.

    I have done chmod 777 -R on conf, cache, uploads as per required for install.

  • Options

    Bump.

  • Options
    peregrineperegrine MVP
    edited May 2013

    I can't think of anything I've changed except for commenting out #bind-address on my.cnf to allow a remote mysql connection only from a single IP.

    what happens when you undo the change you made.

    are you logged in as root admin or another admin. what is your userid.

    log in as the root admin and see what happens.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Of course I'm not logged in as root. Or do you mean Vanilla admin? Yes I'm logged in as the only Vanilla user there is, which is the admin. Can't even post a new topic.

    The conf/cache/uploads are owned by my user with sudo privaledges, and they are the www-data group that php uses. But they're 777 permissions anyway, so that shouldn't matter?

    As far as uncommenting bind-address, that shouldn't matter, unless there is something specific I need to set in Vanilla? My other applications connecting to mysql, both localhost and remotely, work fine. I can't change that, so I'd need a work around if that's the actual problem.

  • Options

    When I try to enable a plugin for example, all it does is refresh the page after doing its little loading animation.

  • Options
    peregrineperegrine MVP
    edited May 2013

    All I did is install it, and try to use it. It was working before, and mysteriously stopped while I can't think of anything I've changed except for commenting out #bind-address on my.cnf to allow a remote mysql connection only from a single IP. But local connection is still allowed, and works,

    As far as uncommenting bind-address, that shouldn't matter, unless there is something specific I need to set in Vanilla?

    it was just an idea to rule out the change - to isolate problem. assumptions and practice are different. it may not be the cause, but at least you rule it out.

    check your sql error logs.

    So, let me get this right.

    1 you installed vanilla it worked. (don't know what original version worked.)
    2 You made changes to mysql.cnf
    3 It still worked???
    4 you upgraded to vanilla 2.0.18.8
    5 immediately after the upgrade it stopped working.

    if the steps are incorrect - correct them.

    I can install it. I can't make posts. I can't change themes. I can't activate plugins.

    Also disable your plugins in config.php (change them to false all except htmlawed) and change to the default theme in config.php, remove any changes to vanilla.

    and see it that helps. Then look at your permissions in dashboard for admin role to see if they allow posting. Create a new admin user and see if the new admin can post.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Oh no. I didn't update it or anything. It just seemed to stop working.
    I completely reinstalled vanilla forums after seeing it wasn't working, so no plugins are active and it's the default theme. I deleted the database before installing, as well. It behaves the same after the reinstall. I can't change plugins, post, theme, or anything.

    As far as mysql errors: I tailed the end of my /var/log/syslog(where mysql errors go in debian), and there are no mysql errors.

    I can not create a new user as you suggested. I can load the "add user" page and fill it in, but it does nothing but refresh the page when confirming it. Just, none of those things at all work. The only thing it'll do is display.

  • Options
    ShadowdareShadowdare r_j MVP
    edited May 2013

    Do you have APC installed and enabled on your server? If so, please clear the APC cache and see if any changes you made show up. One way to do this is to restart the PHP daemon on your server.

    Add Pages to Vanilla with the Basic Pages app

  • Options
    SadakoSadako
    edited May 2013

    @Shadowdare said:
    Do you have APC installed and enabled on your server? If so, please clear the APC cache and see if any changes you made show up. One way to do this is to restart the PHP daemon on your server.

    Weird thing happened when I did that.
    It added a post from my wordpress blog, with just a starting excert, posted by a blank name. But that's it. I still can't add a post or change anything.

  • Options
    ShadowdareShadowdare r_j MVP
    edited May 2013

    You should disable APC completely for now to see if that changes anything. Restarting it just cleared the cache for that instance in which some changes might not have been processed.

    Add Pages to Vanilla with the Basic Pages app

  • Options

    I do not have APC or memcached installed/enabled.

  • Options

    I created an entirely new server. Installed Debian Wheezy, php, mysql, nginx. Installed vanilla.

    Same exact issue. ... I guess it could be that I use cloudflare and only accept traffic on port 80 from cloudflare by my firewall.

  • Options

    It works when I visit the site directly by the ip, but not when I visit by the url. Maybe it is something to do with Cloudflare, but I'm not finding others with that issue.

  • Options

    it sound like a issue with cloudflare setup. Are you using

    http://vanillaforums.org/addon/cloudflaresupport-plugin

    grep is your friend.

  • Options

    No. That plugin only works for 2.1, it says. I'm using 2.0.18.8.

    Also, it just says it is to show their ip. Is that really the issue stopping anything from working? It sounds like all that does is make their ip field in DB update correctly. Is that actually necessary for basic operation of the forum?

  • Options

    you aren't the first to use cloudflare with vanilla though

    grep is your friend.

Sign In or Register to comment.