Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

SSO not working with 2.1b

I am using Vanilla jsConnect with Vanilla 2.1b and while it's creating the Vanilla accounts as it should, it does not seem to log them in correctly.

It seems to see their cookie fine, showing the "Sign in with sitename" message. When you click that, it doesn't actually sign you in. It only creates the Vanilla user.

I don't know if it's a plugin issue not working with 2.1b, or what, but I need to use SSO.

Best Answer

Answers

  • SadakoSadako
    edited June 2013

    If I disable sso and try to sign into one of the accounts created by it, I'll get "Your account does not have a password assigned to it yet. Click here to reset your password."

    Test url returns something like this: test({"email":"redacted@gmail.com","name":"redacted","photourl":"","uniqueid":1,"client_id":"50026redacted","signature":"ecc3d8826db28c0333eec149d0redacted"})

    It was working in 2.0, but those forums stopped working and I upgraded them to 2.1b

  • Actually, signing in just doesn't work at all, except for the admin account that was first created. I tried the main 2.1 branch as well.

  • SadakoSadako
    edited June 2013

    I tried 2.0.18.8 but I get an issue where no one can post at all.

    I tried the "master" branch, but that has no styling at all, just plain html.
    I also tried hosted vanilla forums, but then I noticed you need the 2nd plan to use SSO, and it says I don't have "permissions" to change the plan, or cancel it.

  • It works when directly connecting to the IP, bypassing cloudflare.

    It doesn't work behind cloudflare.

    Anyone? :/

  • I set it up on a normal DNS(name.com) instead of cloudflare and it still does not work.

    It works when visiting the IP directly.
    I'm not using $Configuration['Garden']['RewriteUrls'] = FALSE; so I don't see why nginx or the domain name would be an issue.

  • I guess I should note that i've tried both cgi.fix_pathinfo 0 and 1, since I've seen that a long with other "path" things come up with nginx discussions.

    But in this case it's working fine when I visit http://ip/forums but not when I visit http://www.example.org/forums

  • One other thing.
    The "master" branch works, but that has no styling, or javascript, or anything. Is there a way to have that but with styling?

  • hgtonighthgtonight ∞ · New Moderator

    I have no experience with these plugins, I just want to say keep doing what you are doing.

    Experiment, test, and report results!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.