Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Can't install Vanilla 2?

So I've finally figured out my problems with wordpress and have been able to get into the log in screen to install Vanilla, however - I am now getting this error: Failed to connect to the database with the username and password you entered. Did you mistype them? The database reported:
SQLSTATE[28000] [1045] Access denied for user 'danatoth_one'@'ns6092.hostgator.com' (using password: YES)

I at first thought it was because the user didn't have enough privelages, but I checked and the user has all priverlages enabled.

Here are screen shots of my DB and Error:

http://imgur.com/CMGKmLJ,cniun5y#1
http://imgur.com/CMGKmLJ,cniun5y#0

Best Answers

Answers

  • Options

    I'd like to note that it asks for a DB password, but I was never given an option to put in a database password when creating the database, only a password for the user - this is the password that I have used.

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    It's not a great idea to post such information on the Internet!

    Your user looks like it is simply

    danatoth_one

    so why are you adding the rest?

  • Options
    DanatothDanatoth New
    edited June 2013

    I'm sorry, I don't know what you mean by "so why are you adding the rest?" I only added user danatoth_one to the danatoth_1 database in cpanel.

  • Options
    hgtonighthgtonight ∞ · New MVP

    Is this the same db and user that you use for Wordpress?

    If so, you should be able to find the db info in wp-config.php in your Wordpress install directory.

    Welcome to the community!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    In the error report:

    danatoth_one'@'ns6092.hostgator.com

  • Options
    hgtonighthgtonight ∞ · New MVP

    @whu606, the db user password will also be in wp_config.php.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    @hgtonight said:
    Is this the same db and user that you use for Wordpress?

    If so, you should be able to find the db info in wp-config.php in your Wordpress install directory.

    Welcome to the community!

    No, this isn't the same DB I use for wordpress. Wordpress is in my root, my forums are in a subdirectory called /forum/

    I'm not sure why it is denying access to my user for the new database I created, I've checked the users privileges and it has all privileges enabled. Vanilla is asking for the password to the database, but I did not add one when I created it, I only added one for the user.

    I have tried using the user's password, leaving it blank, and every other password that I have used for any other access on the website and I continue to get this same error.

    I'd also like to thank you for welcoming me to the community, I hate to have my first posts be troubleshooting, but I hope that they can help someone out someday - if the same problem arises for them as well.

  • Options

    @hgtonight said:
    It is asking for your mysql user password.

    Did you add the user to the db? You should be able to see all assigned users per db in your cpanel.

    Indeed I did, as you can see in this SS: http://i.imgur.com/CMGKmLJ.jpg

    The user is added to the DB and all permissions are granted. I am using the password assigned to that user as the password
    in vanilla forums, and yet I still recieve this error.

  • Options

    @hgtonight said:
    My bad :D

    Have you tried using localhost has the host?

    This worked, I guess since it's already accessing the folder, localhost would be referring to the server it's on and not my local machine :P Thanks for the help :)

Sign In or Register to comment.