Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Wanting all users to receive email notifications on new posts

I need to change settings so that all forum members get the email notification of any new posts. What is the best way to do this?

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    What version of Vanilla are you running?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I'm having this same issue @hgtonight

    I am using Vanilla 2.0.18.8

    Thanks for any help.

  • hgtonighthgtonight ∞ · New Moderator

    What issue are you having?

    What have you tried?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • TamaTama United Kingdom ✭✭✭

    @LucasKA I pulled these from the list of configuration options on the repo

    $Configuration['Preferences']['Email']['ConversationMessage']   = '1';
    $Configuration['Preferences']['Email']['BookmarkComment']       = '1';
    $Configuration['Preferences']['Email']['WallComment']           = '0';
    $Configuration['Preferences']['Email']['ActivityComment']       = '0';
    $Configuration['Preferences']['Email']['DiscussionComment']     = '0';
    $Configuration['Preferences']['Popup']['ConversationMessage']   = '1';
    $Configuration['Preferences']['Popup']['BookmarkComment']       = '1';
    $Configuration['Preferences']['Popup']['WallComment']           = '1';
    $Configuration['Preferences']['Popup']['ActivityComment']       = '1';
    $Configuration['Preferences']['Popup']['DiscussionComment']     = '1';
    $Configuration['Preferences']['Email']['Mention']               = '0';
    $Configuration['Preferences']['Popup']['Mention']               = '1';
    

    add the ones you need to your conf/config.php file, 1 = true 0 =false

    There was an error rendering this rich post.

  • I'll see if that works out, thanks a ton.

  • TamaTama United Kingdom ✭✭✭

    @LucasKA said:
    I'll see if that works out, thanks a ton.

    I believe advanced notifications cover this, in hindsight I think you may need to search around about for configs for them

    There was an error rendering this rich post.

  • In all the docs, anything to do with the config file is non-existant :(

  • TamaTama United Kingdom ✭✭✭

    I method that could work would be the following, changing the default row value for preferences for users to the value taken from a user who has advanced notifications for all the categories you want.

    There was an error rendering this rich post.

Sign In or Register to comment.