Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Spell Checker

blizeHblizeH ✭✭
edited August 2007 in Vanilla 1.0 Help
... isn't functioning correctly, it doesn't seem to matter what you type now, it'll search for spelling corrections, idle for about 10 seconds and return saying that it didn't find any problems, huge shame because the spell checker was bloody fantastic!

Using the v1.0 pre-release btw.
«13

Comments

  • Options
    Same for me
  • Options
    blizeHblizeH ✭✭
    Hmm, even the fontsize on the forum seems to of got smaller, argggggggh!

    /bangs head against desk

    Why's my Vanilla installation breaking so much all of a sudden? We've had no problems for 5 months or maybe even more, yet all of a sudden everything seems to be breaking.
  • Options
    when did it stop working? did you change anything just before?
  • Options
    actually i think i know what it is... google has switched their spellchecker to ssl. i'll update the extension. it needs an update to use the new googiespell anyway.
  • Options
    Why not create an extension using Aspell?
  • Options
    because not everyone has the aspell libraries on their systems :)
  • Options
    blizeHblizeH ✭✭
    Any news on this please? I loved the spell checker <3
  • Options
    edited July 2006
    Googie Spell has a fix. Replacing the contents of the current sendReq.php file with the new code should get you running again:

    <?php // Thanks to: // Marcin 'nosferathoo' Puchalski // Johan Sijbesma // James Edgington // Stephen Wald $google = "www.google.com"; $lang=$_GET['lang']; $path="/tbproxy/spell?lang=$lang"; $data = file_get_contents('php://input'); $store = ""; $fp = fsockopen("ssl://".$google, 443, $errno, $errstr, 30); if ($fp) { $out = "POST $path HTTP/1.1\r\n"; $out .= "Host: $google\r\n"; $out .= "Content-Length: " . strlen($data) . "\r\n"; $out .= "Content-type: application/x-www-form-urlencoded\r\n"; $out .= "Connection: Close\r\n\r\n"; $out .= $data; fwrite($fp, $out); while (!feof($fp)) { $store .= fgets($fp, 128); } fclose($fp); } print $store; ?>
  • Options
    bshultz - You're a lifesaver. Thanks for the fix - works like a charm!
  • Options
    Just installed this extension. Wasn't working at first, but upon replacing SendReq.php with code mentioned above, worked great. The only other problem I had was that to get the images to display (indicator.gif, ok.gif, etc) I had to go into the googiespell.js file and manually set the paths to the images. thanks for the great tool! cheers
  • Options
    edited July 2006
    In the file default.php, change the line:

    'var g = new GoogieSpell("./' . $ExtPath . 'googiespell/", "' .
    to this:

    'var g = new GoogieSpell("/' . $ExtPath . 'googiespell/", "' .
    and your image paths will work as expected.
  • Options
    Thanks a bunch for the update, awesome add on. Very clean!
  • Options
    a_ja_j
    edited July 2006
    Thanks for the input, but unfortunately it did not work. The spellcheck image doesn't show, the indicator shows a blank box for a second, then dissapears, and there is no OK button on the suggestions. I have everything installed in the extensions folder; no tweaks to file hierarchy. thanks again.
  • Options
    blizeHblizeH ✭✭
    Hmm, I've just updated my sendReq.php file but still not having any luck unfortunately, this time it's not timing out, it's just displaying as no errors found straight away :(
  • Options
    bschultz - Thanks again. Worked perfectly. ^_^
  • Options
    blizeHblizeH ✭✭
    Any ideas why mine still isn't working please guys?
  • Options
    updated this extension - sorry for the delay. try the new one blizeH.
  • Options
    Are you still having this trouble blizeH? If not, have you found a solution? I'm working with a new installation of Vanilla and I'm having the same spell checker problem blizeH was: when you try to check the spelling it always comes back immediately and says there are no errors even if I specifically put errors into the post. I've tried the php code updates posted above as well as uninstalling and reinstalling the extension. Any ideas?
  • Options
    which version of the extension are you using?
  • Options
    I pulled it down 2 days ago, but the file doesn't have a version number or a readme so I can't confirm that it is the most recent.
This discussion has been closed.