Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] "Code":401,"Exception":"This Category only accepts links posts"

edited September 2013 in Vanilla 2.0 - 2.8

Hi.
Two days ago I start receiving a message when trying to edit my own post.
I mean, I can write the message, it let me post it, but for example, if I forgot something to write or trying to correct some writing mistakes, I receive this message: {"Code":401,"Exception":"This Category only accepts links posts"}

I entered phpmyadmin and in GDN_Discussion field, I could edit the post and the changes appeared in the forum.

Can you help me in this matter so that I can make changes directly into the forum window, as it was two days ago? I saw others had the same problem, but I couldn't find an exact answer for a beginner like me.

Thanks,

Florian

Tagged:

Best Answer

Answers

  • Options
    hgtonighthgtonight ∞ · New MVP

    Welcome to the community!

    What version of Vanilla are you running?

    What did you do two days ago? Did you change themes, enable or disable plugins, change configurations?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Reading the readme file, I see that I have Vanilla version 2. I installed some plugins, I can't remember which one. As far as I remember it all started when I tried to solve a problem regarding the CATEGORY menu. All the categories were disabled so I couldn't put a post in a certain category. I searched the net and I found some indications that sent me to the phpmyadmin and in GDN_category, I tried to change the categoryID of the items I had to "-1". It didn't work.
    Now I deleted them all and it remained only the default category.
    I guess it all started from here. I am zero at php of programming so I all did was trying to follow some step -by-step indications.

    I'll be happy if you can help me with some advices.

    Thanks again

  • Options

    Please click the link in hg's post & read. All Vanilla versions are 2. We need to know : 2.0.18.8 or 2.1 or 2.2. The category problem... may I suggest you solve it in a different way?

    There was an error rendering this rich post.

  • Options

    Sorry, my bad. Vanilla version is 2.0.18.8

    Regarding the category problem, I am opened to any suggestion. For the moment, I disabled categories, as I couldn't link any post to any category I created.

  • Options

    You were right. I disabled the plugin and everything worked right. I could edit the post. Thank you very much peregrine

  • Options

    you probably just have to set the permissions for categories correctly in the dashboard when using the plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    yes, I will check them. It'll be good to have categories, so that the members can post i na certain category. Is it possible that the RateMyLink plugin unabled my categories?

  • Options
    peregrineperegrine MVP
    edited September 2013

    @cheilenereinfo

    I don't use the plugin. Read the description and readme carefully and look at settings, best i can suggest. Then if you have further questions. Post a new question in the plugin questions and I'm sure x00 will have answers.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Ok. Thanks again for your great help. All the best

  • Options

    @cheilenereinfo said:
    Is it possible that the RateMyLink plugin unabled my categories?

    It Is possible that the error message you received was generated by that plugin. Hopefully something with permissions and settings to solve

    There was an error rendering this rich post.

  • Options

    I created the categories again and this time they all worked well. I could link the posts with the categories. So coincidence or not, after I disabled the plugins, everything worked fine.
    thanks again to everybody

Sign In or Register to comment.