Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

permission error when creating discussions

I just set up a new vanilla install (2.018.8) and I am having an odd issue. Members can not create discussions, although mods and admins can. I have double (and then some) checked permissions in both roles and categories, members should be able to create discussions. The drop down menu shows the correct categories (the ones members have permission to create in) but the page shows a ¨permission problem, you dont have permissions to do that¨

I have spent all day trying to resolve this issue with no luck. I tried setting custom permissions on all categories as another discussion suggested, this had no affect. I have also tried creating another role, setting the permissions (to what members should be), and it results in the same issue. Members appear to be able to do everything else, except start discussions.

It is the first time i have set up apache and php in debian, my other vanilla installs are running in slackware and work flawlessly, so i suspect something may be misconfigured on the web server end, but really i have no idea what the cause could be. I am somewhat baffled as to why it is only affecting members and not admins and mods.

Any help with this would be hugely appreciated.



  • Options
    hgtonighthgtonight ∞ · New Moderator

    Turn debugging on by placing $Configuration['Debug'] = TRUE; in your /conf/config.php file.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    peregrineperegrine MVP
    edited September 2013

    in version

    I believe you need to turn debugging on with this config

    $Configuration['Garden']['Debug'] = TRUE; via /conf/config.php file

    in vanilla 2.1.x

    $Configuration['Debug'] = TRUE;

    Also, you might post screenshots of the dashboard permissions for each role (specifically members) and the one that works and the roles that don't work it might be more enlightening.

    Can members make comments, on other discussions?

    and list any plugins - you might be using.

    Are you running multiple versions of vanilla in the same browser, where the cookies may be interfering?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    raphaa00raphaa00 New
    edited October 2013

    I'm suffering from this very same problem, but I'm using 2.1b2.

    My debug trace states this:

    Info     Need to re-index theme cache
    Info     Need to re-index plugin cache

    Here's my Member's permissions attached.

  • Options

    Hmm. Interesting.

    I just disabled Discussions Polls plugin and everything is fine.

    And the author just released a version that fixed this.

Sign In or Register to comment.