Please upgrade here. These earlier versions are no longer being updated and have security issues.

Issue with upgrade from vanilla 1 (1.2.2) to vanilla 2.1b (2.1 github branch)

lucluc ✭✭
edited September 2013 in Vanilla 2.0 - 2.8

Hi,

I know it's been a long while since I posted anything, and usually it was not to ask for help, but I need some today :).

I've tried upgrading from vanilla 1 (1.2.2) to vanilla 2.1b (2.1 github branch) .
I'm doing it as my server as been upgraded to php 5.5, and too many things are being deprecated/erroring out with it.

I've successfully exported using porter 1.8 (even it complained about mysql stuff being deprecated, normal as running php 5.5).
I've setting successfully a brand new 2.1 install, and when trying to import the data from the export files I've copied from v1 to v2 in the upload file (on the same server), it keeps asking for the admin login/password from v1.

I've even "changed" the password of the admin from my v1 install to make sure the hash get reset, but to no avail.

Is there some way around this?

Thanks

UnderDog

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome back!

    I believe you have to use the original admin account to use the importer. You should be able to disable that check if you are at all proficient with PHP. You will need to temporarily modify the /applications/dashboard/models/class.importmodel.php file to remove the Authenticate Admin User step.

    As always, back up your data and work in a test installation.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Hi luc,

    Welcome back. Good to see you!

    @luc said:
    it keeps asking for the admin login/password from v1.

    Have no experience with actual upgrades, but when I see a situation like this, I would check the source code and see why it keeps asking for your admin password (if/else statement.)

    If you would like us to help you find the problem / solution, I would ask you to post that code (5 lines above and under that statement) in between ~~~ please

    peregrine
  • @luc

    Come on back. you had great posts. Hope you get it resolved.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • First, thanks for the welcome back.

    @hgtonight said:
    Welcome back!

    I believe you have to use the original admin account to use the importer. You should be able to disable that check if you are at all proficient with PHP. You will need to temporarily modify the /applications/dashboard/models/class.importmodel.php file to remove the Authenticate Admin User step.

    As always, back up your data and work in a test installation.

    Well, I'm not really php proficient, but I manage to hack things when I need. And it's been quite a while since I had to.
    That's what I thought of/try to do yesterday evening but my wife was waiting and I didn't pursue this further.

    Well, at first, I tried to vardump before this (around line 212 in the same file hgtonight talks about):

    //vardump($Result);
                if(!$Result) {
                        $this->Validation->AddValidationResult('Email', T('ErrorCredentials'));
         $this->ErrorType = 'Credentials';
                }
    

    but no "display" of the value, it seemed to work a little bit more (as I see on the forum some previous data), then I tried to set $Result to TRUE so it goes over this "error" and return True in that function (AuthenticateAdminUser) but as the install was still in progress somehow, I had an error when accessing the page to continue the import.

    I'll start over tonight and report back. But it's really strange it doesn't says True right away. And with that, I'm afraid all my users won't be able to connect anymore which will be a bit annoying to say the least :)

  • peregrineperegrine MVP
    edited September 2013

    perhaps you could do it in steps

    vanilla 1 to early vanilla 2.0.x release

    vanilla 2.0.x - vanilla 2.1b2

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderUnderDog
  • lucluc ✭✭
    edited September 2013

    No better luck with using 2.0.18.8.

    So I went back to 2.1b2.

    After doing a $Result = TRUE; before the error, it stepped over number 5. But it got stopped at number 9 (insert tables). Apparantly some cookie got revoked and no access anymore. (see vanilla-error2 and vanilla-error2b).

    Then, I cleared everything again, (removing the change to go over step 5).
    Got blocked at step 5, then got to add DEBUG mode on config.php.
    At the sametime, saw the overwriteemail/password in the conf file, changed it to the actual email address and use current password, and it went through OK.
    As I changed 2/3 things at the same time, not sure what did the trick, but it works now, so it's enough for me.

    I mostly guess (as I had to reimport to get the attachments OK) it might be the email/username part. Had to use the email.
    But not 100% sure whats what as I tried manytimes with the email address, and the password. Maybe it was email/password/check use current password.

    hgtonightUnderDog
Sign In or Register to comment.