Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Changing location of the forum and FileUpload images are still showing old location

Hi, I know I am forgetting to change some setting but I couldn't find an answer in the forum. So what did I miss? I changed from www.domain.com/forum to forum.domain.com. Do I need to change this setting: $Configuration['Garden']['Cookie']['Domain'] = ''; to http://forum.domain.com ? But I did that and it didn't worked. Yes I erased .ini files from cache. I am using 2.0.18.8.

Tagged:
«1

Comments

  • Something strange is also happening. The url gets stuck in previous discussions.. What is happening?!?!

    Help me Vanilla experts, you are my only hope! :)

  • I don't know what I need to do with this one... :/ It says that RewriteEngine is on though..

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please post the contents of the htaccess file here use the C button to make it come out nice.

    If you changed the forum root it must change it also in the htaccess file.

  • edited September 2013
    <IfModule mod_rewrite.c>`
    
       `RewriteEngine On`
    
       `# Certain hosts may require the following line.`
    
       `# If vanilla is in a subfolder then you need to specify it after the /.`
    
       `# (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)`
    
       `# RewriteBase /`
    
       `RewriteCond %{REQUEST_FILENAME} !-d`
    
       `RewriteCond %{REQUEST_FILENAME} !-f`
    
       `RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]`
    
    `</IfModule>
    
  • peregrineperegrine MVP
    edited September 2013

    post your test

    uncomment (remove the #) your RewriteBase and point it to the subdirectory where our forum is located, if you haven't already done so.

    e.g. if in forum

    RewriteBase /forum

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderUnderDog
  • edited September 2013

    I don't know if this is important but the forum is now in a forum.domain.com location not in a subdomain.. so change it to

    RewriteBase /forum.domain.com

    huh?
    I am asking because I am afraid to do something that will do things terribly wrong..

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited September 2013

    ok so you

    I changed from www.domain.com/forum to forum.domain.com.

    That means you went from subdirectory to root

    RewriteBase /

    there should not be a # before that

  • peregrineperegrine MVP
    edited September 2013

    rewrite base has to do with the folder you installed the forum (not your website url or domain)

    if you installed the forum on your host in the root folder it should be

    RewriteBase /

    if you installed your forum on your host in /Vanilla

    then

    RewriteBase /Vanilla

    if you installed your forum on your host in /forum

    then

    RewriteBase /forum

    if you installed your forum on your host in /Who/What/Where

    then

    RewriteBase /Who/What/Where

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderhgtonightUnderDogChristianSino
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes and don't be afraid to mess it up, you can just fix it .

    this is what the whole thing should look like

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    
  • I think that this solution doesn't solve the problem in an embedded forum, does it?

    Links work just fine in root directory (without forcing redirect). But inside wordpress (with forced redirect option), opening a discussion in a new tab ends in the embedded vanilla homepage and the address bar still shows the link of the discussion.

  • edited September 2013

    embedded url = www.domain.com/forum/

    real url = forum.domain.com

    previously real url = www.domain.com/forum1

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    make sure this link is right in the config.php

    $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = 'http://forum.domain.com/';

    hgtonightUnderDog
  • RemoteUrl is www.domain.com/forum/

    which is what I describe as embedded url and I hope to remain the same before and after the server change. The only thing that I want to change is the original directory of the vanilla.
    Nevertheless, I changed it and the forum now isn't embedded any more..

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited September 2013

    ok try adding this , change true to false or vise versa see which works

    $Configuration['Plugins']['EmbedVanilla']['ForceRemoteUrl'] = TRUE;
    $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = 'this url is the url of where it is embedded';
    

    for example if embedded in a blog like I did here the link is for the page where it is embedded

    http://www.vrijvlinder.com/blog/forum/

    let me put it another way

    your stand alone forum is in forum.domain.com/

    You copied the embedded code into a page in www.domain.com/ and the link to it goes to forum/ ?

    so the embed url would in fact be www.domain.com/forum/

  • edited September 2013

    That is the way I had it and it works the right way with

    $Configuration['Plugins']['EmbedVanilla']['ForceRemoteUrl'] = '1';

    $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = 'http://www.domain.com/forum

    But opening a random discussion link in a new tab opens the unembedded discussion and then redirects to www.domain.com/forum/ (in safari) or www.domain.com/forum/url of the discussion (in firefox). In each case the content that it shows is the Vanilla homepage.

  • I can of course give you the url to see exactly what is happening.

    saxolist.com/planet/

    real vanilla url: planet.saxolist.com

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited September 2013

    there seems to be a conflict . Do you have another htaccess file in http://www.domain.com/forum ?

    When it re routs , does it open a new window? or refreshes in the same window ?

    remember to clear the cache files ini files etc every time you make a change

  • www.domain.com/forum (or saxolist.com/planet in my case) is the remote url so there isn't actually a folder for a .htaccess file to exists.
    It refreshes in the same window.

    I think I wasn't very clear about it so pls visit www.saxolist.com/planet and try to open a discussion in a new tab...

  • As you might see any fileUpload image has the saxolist.com/forum/upload address which now should be planet.saxolist.com/upload.

    I don't know if the two problems are related but both happened after the change in the directory of the forum

Sign In or Register to comment.