HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Bonk error when trying to single sign on from wordpress

"NetworkError: 500 Internal Server Error - http://www.100it.be/demo/vanilla/entry/jsconnect?client_id=357054042&Target=/"

Wordpress version: 3.1.6 - Vanilla integration: Version 1.1.14
Vanilla version: 2.0.18.8 - jsconnect version: 1.0.3b

Comments

  • When you get an 500 error you will go into the error logs and ....

    When you get a Bonk error you will search the Wiki and ...

    peregrine
  • peregrineperegrine MVP
    edited October 2013

    Welcome to the community! Happy to have you!

    just for clarification a Bonk error displays the bonk page. Does it say Bonk?

    I also suggest you upgrade to vanilla 2.0.18.8 or you may have more severe problems due to security issues.

    I don't believe a 500 error is a "bonk" error.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    You will need to diagnose what is causing the 500 internal server error. Here is a word press support forum topic about them: http://wordpress.org/support/topic/diagnosing-an-internal-500-error-help

    Usually, you just need to access your server logs and go from there. Since how you access them is highly dependent on your web host, I also suggest contacting them. Check there website first for some FAQs regarding server logs.

    Good luck!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • thanks for your welcome!

    its a

    Bonk - Something funky happened. Please bear with us while we iron out the kinks.

    http://vanillaforums.org/profile/36251/peregrine I'm using 2.0.18.8, all versions see my first mail.

    there are NO error messages in my appache logs.
    I'm using a shared server and do not have full command line control; but I can see the log file via my customer panel.

    I also tried Vanilla 2.2.4 from Git but this gives me a:

    Something has gone wrong.

    We've run into a problem and are unable to handle this request right now.
    Please check back in a little while.

    After installation and SSO setup

    NOT funky at all....

  • peregrineperegrine MVP
    edited October 2013

    my mistake on version, sorry.
    so when you use change the config.php to make the bonk produce the actual error message - you get a 500 error?

    I'm a bit confused.

    you added these to config.php and then you saw 500 error, or you didn't add these yet, or you no longer get 500 error?

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';    
    $Configuration['Garden']['Debug'] = TRUE;
    

    just a wild guess - download and reinstall jsconnect and reconfigure accordingly.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • 100IT100IT New
    edited October 2013

    Changing config.php like you suggested showed that there were write restrictions in the cache. Good advice, thanks. Solved this

    But now I get endless "connecting ..." with no progress & no error messages....

    Just to be clear:

    I generated the client id and secret in the vanilla plugin (JS Connect Settings)
    and put these in the Wordpress Vanilla Single Sign-on Integration plugin...

    Thanks for your help!

    UnderDog
  • Got version 2.2.4 working but I get the same "connecting..." message when I try to login Vanilla using Wordpress credentials. Logout doesn't work either. The system logs out of Wordpress but the Vanilla session remains logged in.
    bummer.

  • @100IT said:
    I get the same "connecting..." message when I try to login Vanilla using Wordpress credentials. Logout doesn't work either. The system logs out of Wordpress but the Vanilla session remains logged in.

    That might be a good description for a bug report on Github. Make sure you know the details in your FireBug or Chrome equivalent

  • Thanks UnderDog, as you can see from the screenshot attached, no error messages are generated and the apache logs show no errors.

  • hgtonighthgtonight ∞ · New Moderator

    What is the response of the request?

    You should be able to view it through your web inspector.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • 100IT100IT New
    edited October 2013

    Blank screen, saying "connection...." . html (page source)

    (I've translated the values from Dutch)
    While the page continues displaying "connecting..." !

  • hgtonighthgtonight ∞ · New Moderator

    That is the response from the server in the GET request?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Are you using the official wordpress vanilla plugin for jsConnect? It relies on some hook that are often not included in wordpress themes, may even be depreciated

    A much better way of setting it up
    http://wordpress.org/plugins/wp-vanilla-connect/

    You can use the two plugins together with wp-vanilla-connect for js connect

    grep is your friend.

    UnderDog
  • @100IT said:
    Thanks UnderDog, as you can see from the screenshot attached, no error messages are generated and the apache logs show no errors.

    The response of the GET request is 200, but that 'connecting...' part is pure javascript, ajax, etc. See if you can follow x00's advice

  • hgtonighthgtonight ∞ · New Moderator
    edited October 2013

    @UnderDog said:
    The response of the GET request is 200, but that 'connecting...' part is pure javascript, ajax, etc. See if you can follow x00's advice

    That is just the status response code. The actual response can be found (in Firebug) by clicking the little + symbol and selecting the response tab.

    The status might be fine (200) and no data is being returned.

    Just a possibility.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDog
  • @hgtonight said:
    The actual response can be found (in Firebug) by clicking the little + symbol and selecting the response tab.
    The status might be fine (200) and no data is being returned.

    Oh man! I completely forgot about that! Thanks for the info

  • Underdog, hgtonight; thanks for the support.

    I was using: http://wordpress.org/plugins/vanilla-forums/

    I changed this, like you suggested to
    http://wordpress.org/plugins/wp-vanilla-connect/

    Which works now, thanks! connection is made.

    question:
    It would be nice and more secure when LOGGING OUT of Wordpress, the Vanilla session would be logged out to.

  • If on the same domain you can simply delete the cookie. Cross domain there are hacks.

    grep is your friend.

  • Try add this to your themes functions.php

    function vanilla_logout_function(){
       setcookie ("Vanilla", "", time() - 3600);
    }
    add_action('clear_auth_cookie', 'vanilla_logout_function',1);
    

    grep is your friend.

    hgtonight
Sign In or Register to comment.