Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Remember me still doesnt work on v1?

rockwaldorockwaldo New
edited July 2006 in Vanilla 1.0 Help
Very odd. Just installed rc3 as an upgrade.

It doesnt seem to be setting a cookie at all by the looks of it? Any ideas chaps?

here's the test.

Load up browser
Close Browser
Load up new Browser

hasnt remembered, need to login again each time?

I have the domain set at ""
and the cookie location at "\vforum"

I've read somewhere to try without the www, but "" makes no difference...:(


  • Your cookie location needs to include the domain. use
  • Thanks for the help Minisweeper, but i just cant get this bloody thing to work...:(

    Ive tried the following in both the cookie location and the cookie domain boxes as well as on their own:

    NONE of them work....bugger.
  • I see. Sorry i was a hint confused earlier. That's very strange indeed then. Do you use cookies anywhere else?
  • oh yes.

    they work on this very forum for example.
  • MarkMark Vanilla Staff
    Your domain should just be your domain. Your cookie path should be your local path followed by a trailing slash. For example, here are my settings for

    Path: /vanilladev/

    Once you save the settings, you should sign out and go somewhere else with your browser like
    Then clear your cookies just in case there are some old saved ones that are causing conflicts.
    Then close all instances of that browser that are open.
    Then open a new browser, go to your forum, sign in with remember me checked.

    At that point you should look in firefox to make sure that the cookies were created successfully. It has a nice cookie browser built in that allows you to filter down to domains quite easily. Make sure they saved as you specified.

    Then do the "close all browsers and come back" test to see if it stuck.
  • When i said anywhere else i meant anywhere else on your server. Looks like mark has this one covered though :)
  • Cheers Mark

    Didnt stick.

    As for the other stuff on the server, yes - i have a test forum here: and that DOES work. Its set up exactly the same way, on exactly the same server.

    really odd
  • MarkMark Vanilla Staff
    edited June 2006
    I bet that's your problem.

    You've got two different forums setting the same cookies & session variables.

    Open up your conf/settings.php file in your main forum and add this:

    $Configuration['COOKIE_USER_KEY'] = 'mainforumcookieone'; $Configuration['COOKIE_VERIFICATION_KEY'] = 'mainforumcookietwo'; $Configuration['SESSION_USER_IDENTIFIER'] = 'MainForumUserID';

    That will rename the cookies and session variables so they don't clash with the other forum.
  • Cheers mark, i'l try that.

    incidentally, looking at the cookies - the stillwater one sets all three cookies, but the main one (tombstoned) doesn't create the non-session cookies it only creates a session cookie
  • Just tried that MArk and it still doesnt work.

  • I feel like a right pain here - sorry by the way.
  • MarkMark Vanilla Staff
    hahaha - stop saying it's crazy :)

    There is a reason it's not working, and we can figure it out.

    Okay, so you changed the names of the cookies and sessions in ONLY ONE of the forums.

    When you sign out, clear your cookies, close your browsers, re-open your browsers and sign in with remember me checked, what do you see when you look for cookies in firefox? Do any show up? If so, which ones?

    Better yet, I just applied for membership. approve me and let me see what's going on...
  • If you log out of the one which does work and log in to the one that doesnt does it then work? Thought i might aswell throw some ideas into the mix.
  • MarkMark Vanilla Staff
    Can you make me admin so I can play with the cookie settings? I won't break anything, promise...
  • Mark hacked the gibson!
  • Nothing broken yet...:)
  • just signed out of the other forum (as suggested by mini) and i got this error:

    Warning: session_destroy(): Session object destruction failed in d:\domains\\wwwroot\forum\library\People\People.Class.Authenticator.php on line 74

    looks like it managed to do it mind you.

    didnt work though...:)
  • MarkMark Vanilla Staff
    rockwaldo - I'm posting in that private thread on your forum, fyi...
  • I think i have it done now - have a lookie see and let me know when to put it back..:)
  • MarkMark Vanilla Staff
    edited June 2006
    Okay, I know what the problem is now.

    @#$%ing Windows.

    Need to do some research to figure out how to fix it. I hope someone else had this problem and came up with an elegant solution.
This discussion has been closed.