Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Remember me still doesnt work on v1?



  • good investigative work Mark.

    really appreciate your time and effort.
  • MarkMark Vanilla Staff
    For the record, this is the problem:;en-us;q176113 The real problem is that I set the cookies and then the login page tries to redirect you to the index page with a header("location: index.php"); type of line. On some windows servers, this isn't handled properly (See the above link). I don't really know what to do to fix it. I don't really want to change the code in case it breaks for *other* servers that work properly.
  • Ok, well i have submitted a ticket to my hosting company, i'l let you know what they say
  • How about following the header with HTML containing a meta-refresh? If the header fails, it will fall back on the meta-refresh.
  • MarkMark Vanilla Staff
    I don't want to have to change the code like that. I hate it when pages "flicker" like that. This is all very frustrating.
  • dont panic chaps, lets see what the hosting lads say - it may be a very isolated thing
  • lechlech Chicagoland
    Shoot Self in Foot: Object "Foot" will be included in the next release. You can upgrade for $500.
  • edited June 2006
    Man, this is a tough PITA. One helpful discussion I found: Possible workaround method: (sensing the server type and version, then using some sort of alternative redirect) A really familiar name, but the wrong fix:
  • edited July 2006
    updated to the latest vanilla release this week......and my forum posters have reported this problem too - ie having to login each time I changed the cookie settings, as Mark suggested....will see if that works in the next day or two
  • MarkMark Vanilla Staff
    let us know either way if it works out for you. I'm sure the cookies are programmed properly now - it's all a matter of configuring their domain/path properly.
  • edited July 2006
    hasn't worked, Mark. I have had feedback tonight.......and the problem persists. (nb - my settings were changed earlier today to what you recommend joy)
  • hehe oh i get it, only just realised thats happening to me on my localhost ( windows ). But i ont care but it woul be nice to have fixed. It never did it before.
  • UPDATE - great subscribers are all now reporting good things today. They are now finding that they are staying logged in. Only one has had problems - he is now fine from his work pc, but has to re login from his home pc, but he says he uses AOL at home (so thinks that may be the issue)
This discussion has been closed.