Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Peregrine Reaction - how to make it work with production version 2.0.8.x?

I'm using the production Vanilla Community version - 2.0.8.x
The Peregrine Reaction plug-in doesn't install as it requires 2.1

Is there some way i can make it work with the 2.0.8.x?
Also, how is it different from the Vanilla Reaction on the hosted version?

Kiran

Comments

  • Options
    peregrineperegrine MVP
    edited October 2013

    I'm using the production Vanilla Community version - 2.0.8.x

    • personally I'd be more worried using Vanilla Version 2.0.8.x
    • My reaction is your version 2.0.8 is way outdated and must be missing numerous security patches.

    Welcome to the community.

    The Peregrine Reaction plug-in doesn't install as it requires 2.1

    Correct. it does require 2.1 or above.

    Is there some way i can make it work with the 2.0.8.x?

    Sorry. No. answered this question when a previous poster asked

    Also, how is it different from the Vanilla Reaction on the hosted version?

    I thought i answered that in the readme and description and screenshots. What you see in screenshots is what you will get.

    I highly suggest you move your forum to vanillaforums.com hosting, if you need it badly.

    They could probably set you up with a working version of vanilla with reactions.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    businessdadbusinessdad Stealth contributor MVP

    I absolutely agree with @peregrine, you should update your Vanilla installation as 2.0.8 is way behind.

  • Options
    hbfhbf wiki guy? MVP

    @peregrine what issues does this plugin have with running on 2.0.18.8? if one were to (not so) cleverly change the the plugin information to remove the version requirement, would you expect it to work or are you using some hooks that only exist in 2.1?

  • Options
    peregrineperegrine MVP
    edited October 2013

    hbf said ..... change the the plugin information to remove the version requirement

    @hbf no that won't work - the requirement is not an empty requirement it serves a purpose because the plugin actually does require 2.1

    check out the I liked this plugin, or thankful plugin, or karma plugin, or about 5 other plugins that perform some of the same functions if you need a plugin for a version less than vanilla 2.1

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited October 2013
  • Options
    peregrineperegrine MVP
    edited October 2013

    good point V.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    hbfhbf wiki guy? MVP

    I wasn't asking for him to make anything. I was just curious as to what special new thing in 2.1 he used. But given the response I'm not interested one way or the other at this point. I won't be returning to this thread.

  • Options
    peregrineperegrine MVP
    edited October 2013

    @hbf the majority of the code is dependent on something about 2.1

    donations for the plugin! are welcome from vanilla 2.1 users.

    To everyone else... please re-read

    http://vanillaforums.org/discussion/comment/194508/#Comment_194508

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    peregrineperegrine MVP
    edited October 2013

    I cut and pasted this from another thread from July.


    I've got as much of the features I plan to add in this version.

    It will run in vanilla 2.1 ONLY

    I plan to release it when I get a few more monetary pledges

    edit: I released it too soon, before the prerequisite pledges from multiple people with no strings attached.

    Here are the specs and some screenshots.

    • it will not work in 2.0.18.8

      • it will not have a hover for the reactions clicks.
      • it will not display a discussion list in the profile of who clicked on what.

      • it will not have good looking badges or icons, but placeholders. (you can put whatever icons you want in there)

    What it currently will do upon release:

    text and badge name and reaction names will be translatable through definitions

    there will be four reactions.

    the points will be added 1 point per click.

    the points will be tallied for an individual upon signin or upon viewing the individuals profile (the same exact way the current badges plugin works now.

    four numbers will appear in the activity page.

    the peregrine leader board plugin will show the top point leaders.

    the membership enhanced plugin and the peregrine badges plugin have been modified to work with the peregrine reactions plugin.


    another comment. from July.

    xxxxx said: this is awesome, too bad we will be using 2.0.18.8 for a while longer. what amount is necessary to make it work with 2.0.18.8?

    thanks for the awesome, but....

    Hmm, what would I do in a situation like this. Would i upgrade to vanilla 2.1 for free, or would I ask for a quote from a person who has repeatedly said they don't do quotes :smile:

    If I did it for 2.1.18, the next person using version 1.x would expect me to do it for them also, and I don't want to be unfair.

    I think better use of my time would be improving feature for use in 2.1 wdyt? I'm a just waiting on donations without strings attached, and maybe I'll add more features.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    hgtonighthgtonight ∞ · New MVP

    @hbf said:
    peregrine what issues does this plugin have with running on 2.0.18.8? if one were to (not so) cleverly change the the plugin information to remove the version requirement, would you expect it to work or are you using some hooks that only exist in 2.1?

    I did this awhile ago. 2.0 is missing some event hooks this plugin relies on. Most notably: DiscussionController_AfterReactions, ProfileController_AfterUserInfo, and DiscussionController_AuthorInfo. It may also rely on other infrastructure improvements in 2.1. I didn't bother looking into it further.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.