Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

ODBC Error

This discussion is related to the SphinxSearch addon.

Hi,

I am trying to install your plugin and the installer aborts because of the following error. Can you advise me what I need to do?

"ODBC source support will not be available. Unable to proceed due to the following errors." I am not a total novice but I am not sure what I need to do here.

Thanks,
Manning

Comments

  • I can get Sphinx to install directly through SSH but it won't reference the plugin dashboard. Is there a solution for this?

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    Try installing with your distro or manual method. When that is done, go through the install wizard again and paste in the locations of searchd/indexer and then paste your config file. Once that is done, copy and paste your new config over your original config (make a copy first of your original)

    UnderDoghgtonightShadowdare
  • I installed sphinx through SSH and checked my usr/local/bin directory and I see both the indexer and searchd files in there. I also see in my etc folder sphinx.conf.dist and sphinx-min.conf.dist. A bit lost from here. I tried to put the paths in the manual indexer field and it failed. It recommended that I turn logging on but not sure how to do that on vanialla forums. Any help would be appreciated.

    Thanks.

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    Yes, put the location your indexer and serachd paths in the installer. Then paste your sphinx.conf.dist contents in the text box. What is the error message after you do this?

    UnderDog
  • Hi. Sorry for the long delay in responding. I did that today and it gives me this message: "ManualIndexerPath not found at: /usr/local/bin/indexer
    May also try turning on all errors, error_reporting(E_ALL);, to see if 'open_basedir restriction is NOT in effect". Any advice?

  • peregrineperegrine MVP
    edited November 2013

    ManualIndexerPath not found at: /usr/local/bin/indexer

    does the indexer exist in /usr/local/bin??

    find out where indexer is located and point your path appropriately.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Here is a screenshot of the file location.

  • peregrineperegrine MVP
    edited November 2013

    I may be running interference with mcu_hq so if he tells you something different - listen to him, but in my version of sphinx setup. I don't know if I have an older version of sphinx plugin. but if you have the same statements. you can look at them

    In my /conf/config.php - you may have

    $Configuration['Plugin']['SphinxSearch']['ManualIndexerPath'] = '/usr/local/bin/indexer';

    is that correct?

    what happens when you type

    /usr/local/bin/indexer from the console.

    do you get help message.

    also look in your log files for sphinx - you can find location of log files in the sphinx.conf in etc

    and

    check your process list for the searchd daemon, is it even running?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Hi Peregrine. Actually I have the following:

    $Configuration['Plugin']['SphinxSearch']['ManualIndexerPath'] = FALSE;
    $Configuration['Plugin']['SphinxSearch']['ManualSearchdPath'] = '/usr/local/bin/searchd';

    How do I check my process list?

    Could this be my issue?

    Thank you for your help.

  • $Configuration['Plugin']['SphinxSearch']['ManualIndexerPath'] = FALSE;

    $Configuration['Plugin']['SphinxSearch']['ManualSearchdPath'] = '/usr/local/bin/searchd';

  • Here are two other lines of code that it is showing it cannot detect.

    $Configuration['Plugin']['SphinxSearch']['IndexerPath'] = 'Not Detected';

    $Configuration['Plugin']['SphinxSearch']['SearchdPath'] = 'Not Detected';

  • hbfhbf wiki guy? MVP
    edited November 2013

    it's not installed / configured correctly. it needs to have an indexer path and a searchd path. it didnt autodetect either of these (which to me means it's probably not installed correctly) you are using a manual path for searchd - verify there is a an executable at the location.

    you need to specify the indexer path. the manual override is set to false and there is no detected path.

  • How do I check my process list?

    what type of os are you using and do you have access to the console.

    in unix/linux -

    ps -ef | grep searchd

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Hi Peregrine and hbf.

    I am using Centos OS on a Linux server.

    I do have access to the console (terminal on mac) and ran the above command. Here is what it returned.

    [[email protected] ~]# ps -ef | grep searchd
    root 7754 7730 0 07:23 pts/0 00:00:00 grep searchd
    [[email protected] ~]#

    Also, when I viewing my discussions yesterday, I had Sphinx "enabled" and it gave me the error below. I disable Sphinx and the error goes away.

    Query failed: connection to localhost:9312 failed (errno=111, msg=Connection refused).

    If I need to reinstall, how can I uninstall everything cleanly and reinstall from terminal?

    Thanks for your help. I am still a novice at managing my own server, although, I am learning how to manage it better. It these type of issues that confound me a bit.

    Manning

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited November 2013

    Query failed: connection to localhost:9312 failed (errno=111, msg=Connection refused).

    This is because searchd is not found running on your localhost on port 9312, so I'd expect that message if it didn't install correctly. What version of the plugin are you using? Sometimes I found that apache does not have read or write permissions outside of your www/http folder, so the plugin will throw a "Not Found" error even if it is there. Place a known file somewhere on your machine and paste its location into the indexer path and then test to see if indexer was found.

    I'll have to look at the code again, but it is also possible to bypass the whole "not found" checks.

  • Plugin version from read me file.

    An advanced search plugin for Vanilla Forums based on the Sphinx Search engine v2.0.6

  • the version number of all plugins is in your dashboard

    look in your dashboard or the source code.

    the version of the plugin is in a yyyymmdd format at the top of the class.sphinxsearch.plugin.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I'm running a bit of interference. but to do a primitive test to get and test sphinxsearch (software) on your centos machine.

    you could try downloading, testing outside of vanilla and any plugins.
    to determine what your problem is.

    then you will know you have working binaries and search works

    then you could install the plugins.

    as far as uninstalling just disable startup of the daemons in your linux init routines on bootup. then run your uninstaller for the binary if centos has that.
    and disable plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    thanks @peregrine

    peregrine
  • Hi Peregrine,

    Wanted to check and let you know that I haven't yet had an opportunity to re-install Sphinx but will soon. Other projects have taken precedence. Thanks for the info above. I will let you know how it works and if it installs correctly this time.

    Thanks,
    Manning

    UnderDogperegrine
Sign In or Register to comment.