HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My Attachments: No Attachments Available

This discussion is related to the My Attachments addon.

Attachments arn't populating under the users attachments tab.

Any thoughts?

Comments

  • peregrineperegrine MVP
    edited January 2014

    perhaps you haven't set the permissions for the roles properly.

    image

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDoghgtonight
  • Wait... wait... can you make the screenshot a bit bigger? I cannot see it correctly!

    There was an error rendering this rich post.

    R_Jperegrine
  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited January 2014

    I can 2nd that under Vanilla 2.0.18.10. It seem like there is a bug somewhere.

    I have users that have about 50 Uploads and just 4 appear, while some show 0 uploads in their "MyAttachments" link in the frontend.

    What i found out is that it might be might be connected with "Select the Maximum Number of Attachments to Display".

    Example of one user:
    If i choose to show 100, 4 uploads are shown.
    If i choose to show 30, 0 uploads are shown.

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
    UnderDog
  • See ... now that looks like a nice bug report. Can you make screenshots @phreak? Same zoom-in as P-doc so I can see correctly

    There was an error rendering this rich post.

    hgtonightvrijvlinderperegrine
  • peregrineperegrine MVP
    edited January 2014

    @phreak said:
    I can 2nd that under Vanilla 2.0.18.10. It seem like there is a bug somewhere.

    I have users that have about 50 Uploads and just 4 appear, while some show 0 uploads in their "MyAttachments" link in the frontend.

    What i found out is that it might be might be connected with "Select the Maximum Number of Attachments to Display".

    Example of one user:
    If i choose to show 100, 4 uploads are shown.
    If i choose to show 30, 0 uploads are shown.

    the way the program works to facilitate performance is to select all attachments of any type up to the max number selected. then it filters based on extension.

    e.g.
    so if you only allow viewing of jpg file attachments it and the user has 1000 zip files that are more recent than the jpgs then it might not show anything. the easy way around this is to increase Maximum number of attachments to display in the config.php

    $Configuration['Plugins']['MyAttachments']['Count'] = '20';

    also if people uploaded files with extensions like theimage.jpeg

    you could change and add extensions.

    Configuration['Plugins']['MyAttachments']['RestrictExtension'] = array('jpg', 'jpeg', 'zip', 'png', 'gif');

    increase it to 500 or to whatever number works best on your forum.

    and remember this is attachments - if it is an inline image it does not retrieve in-line images only attachments.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited January 2014

    @UnderDog said:
    Wait... wait... can you make the screenshot a bit bigger? I cannot see it correctly!

    yes. i'll try :)

    image

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDogvrijvlinder
  • I'll post a fix later today to solve other issues.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @phreak said:
    I can 2nd that under Vanilla 2.0.18.10. It seem like there is a bug somewhere.

    I have users that have about 50 Uploads and just 4 appear, while some show 0 uploads in their "MyAttachments" link in the frontend.

    What i found out is that it might be might be connected with "Select the Maximum Number of Attachments to Display".

    Example of one user:
    If i choose to show 100, 4 uploads are shown.
    If i choose to show 30, 0 uploads are shown.

    @phreak said:
    I can 2nd that under Vanilla 2.0.18.10. It seem like there is a bug somewhere.

    I have users that have about 50 Uploads and just 4 appear, while some show 0 uploads in their "MyAttachments" link in the frontend.

    What i found out is that it might be might be connected with "Select the Maximum Number of Attachments to Display".

    Example of one user:
    If i choose to show 100, 4 uploads are shown.
    If i choose to show 30, 0 uploads are shown.

    see if version 1.6 helps. if you choose 30 now you should see more uploads.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightUnderDogvrijvlinder
  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP

    @peregrine: There seems still to be a problem. I'm not sure why. But some of my users have possible 50+ pictures. Still 7 are just shown.

    Setting are:
    $Configuration['Plugins']['MyAttachments']['SortOrder'] = 'lastdate'; $Configuration['Plugins']['MyAttachments']['Count'] = '100'; $Configuration['Plugins']['MyAttachments']['CSSType'] = 'V'; $Configuration['Plugins']['MyAttachments']['ClickPref'] = 'fancybox'; $Configuration['Plugins']['MyAttachments']['RestrictExtension'] = array('jpg', 'jpeg', 'zip', 'png', 'gif');

    :(

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • hgtonighthgtonight ∞ · New Moderator

    Man.

    I am really liking this plugin!

    @peregrine, I will be making a PR of sorts for this pretty soon.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrineUnderDog
  • peregrineperegrine MVP
    edited January 2014

    @phreak said:

    peregrine: There seems still to be a problem. I'm not sure why. But some of my users have possible 50+ pictures. Still 7 are just shown.

    Setting are:
    $Configuration['Plugins']['MyAttachments']['SortOrder'] = 'lastdate'; $Configuration['Plugins']['MyAttachments']['Count'] = '100'; $Configuration['Plugins']['MyAttachments']['CSSType'] = 'V'; $Configuration['Plugins']['MyAttachments']['ClickPref'] = 'fancybox'; $Configuration['Plugins']['MyAttachments']['RestrictExtension'] = array('jpg', 'jpeg', 'zip', 'png', 'gif');

    :(

    :)

    give me the list of the attachment names for a a particular user that are missing. And what version are you using?

    and are the missing attachments in comments or discussions?

    are they in restricted categories?

    I need a whole lot of information to solve this for you. Since you are the only one reporting a problem.

    I have no idea what the OP's problem is, they haven't responded in a timely fashion.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited January 2014

    @hgtonight said:

    @peregrine, I will be making a PR of sorts for this pretty soon.

    you can pm me changes if you want. or post snippets, or diffs please don't post the whole plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • updated to version 1.7 to allow zip and fancybox to work together, etc.

    @underdog - can you change the category to feedback.

    @selfcommit
    off-topic is not viewable if you are not logged in and is a poor category choice to post in if you are looking for a reponse to a question.

    and @selfcommit read these if you desire they may help (I guarantee they will give you insights. (don't feel abused or insulted or patronized because these links are provided) , it is for your benefit and ours.

    http://vanillaforums.org/discussion/23130/forum-post-ettikett-etiquette

    http://vanillaforums.org/discussion/17954/food-for-thought-forum-etiquette

    http://vanillaforums.org/discussion/25115/how-to-how-can-a-new-user-better-help-the-community-when-asking-a-question

    http://vanillaforums.org/discussion/23483/advice-for-all-those-just-starting-out-with-vanilla

    http://vanillaforums.org/discussion/20231/how-to-become-somewhat-adept-at-modifying-vanilla-to-meet-your-needs-for-free

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
Sign In or Register to comment.