Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

RSS2 in V1

edited October 2006 in Vanilla 1.0 Help
I upgraded from pre1 to v1 today and there are still a few bugs I noticed, especially where add-ons are concerned. The main one which stood out though was the RSS2 feeds. I get this error:
XML Parsing Error: xml processing instruction not at start of external entity
Line Number 2, Column 1:<?xml version="1.0" encoding="utf-8"?>
Hmmm. Any idea what's gone wry?


  • MarkMark Vanilla Staff
    First of all, this isn't really a vanilla bug, it's an add-on bug. The core is what has been thoroughly tested for bugs and completely cleaned up. The add-ons are another thing altogether.

    Now, did you get the latest version of the addon from
  • See BOM with UTF-8 it's a problem mais if you save files with BOM UTF-8 it's good ;)
  • I managed to get it working by messing around with some file permissions. Not exactly sure what shifted it. I realise the Vanilla core is very stable, here's hoping all the addons get updated soon
  • edited July 2006
    I have been having problems using the RSS2 feed for anything other than subscription.

    For instance, I would like to use the feed in conjunction with feed2js and have updated posts show in my blog sidebar. Errors abound:
    Error: Feed failed! Causes may be (1) No data found for RSS feed; (2) There are no items are available for this feed; (3) The RSS feed does not validate.
    Also, trying to feed the RSS2 into a feedburner account brings up errors:
    The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 2: The processing instruction target matching "[xX][mM][lL]" is not allowed.
    I get the same kind of errors with all the variety of uses I have tried... Any ideas?
  • P.S. I used to do a whole heap of stuff with the old Atom feed in pre1 versions...

  • MarkMark Vanilla Staff
    I think we need a feed expert to fix up those extensions. I should contact my buddy franklin_mint. He wrote part of the spec for atom.
  • Any feed experts wanna chip in?
  • edited July 2006
    bumpety bump Seems silly having rss if it can't be used for anything. Any chance of working through this issue? I'm stumped...
  • I'm going to be making use of the RSS feed soon on a new site I'm developing that is making use of Vanilla to drive the bulk of it It'll be cruical that the RSS feeds work ... so I might end up going through the code and seeing if I can find somethign .... I'll let you know if I spot anything when I get to it (hopefully this weekend)
  • thanks for that... my rss/php knowledge is lower than zero, so any help is much appreciated
  • OK dude, I'll take a look.
  • I have noticed a recent upsurge in RSS related posts on this forum. Any progress franklin_mint?
  • hmpf ... its an extension problem of digg, wightwords, Audioscrobblerizer. deaktivate the extensions, the rss will be fine. but, thats not a solution. the extenesions add a blank line to the rss/atom feed in the first line.
  • What would add the extra line?
  • I have no idea, I can't figure it out. Perhaps the first blank line could be removed within the feed extensions?
  • As I said on the other thread (XML parsing error), this worked for me for Audioscrobblerizer: Split the default.php into two 1) the part the Alex wrote & 2) a lastRSS.php file Then added a line to default.php after the extension information: require ('lastRSS.php'); I then put both files in the Audiscrobbler folder and then re-enabled the extension. Job's a good un.
  • uhm... i got this xml declaration error even with all (!) extensions but the corresponding feed extension disabled. any idea? :-/ i did not change anything but editing themes/head.php to point to my own favicon (which should not add any line at all). have a clean vanilla1 install with todays revisions of the plugins.
  • mhhh... sorry for pushing this, but isnt there anyone who can help me with this? :-(
  • i am no expert akb, so i am just thinking out loud here - but did you also do a clean database install with your new vanilla installation?
  • uhm... no, that wasnt possible, because the forums quite big and got thousands (!) of threads...
This discussion has been closed.