HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Obscure Formating errors CLEditor

This discussion is related to the CLEditor jQuery WYSIWYG addon.
Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

V2.1B2, Opera/FF

Hi, back again... :D:D

Here is a Picture of this "Bug"

You can reproduce this error in our Forum:

http://caba.de/CaBaFoRuM/index.php?p=/discussion/2508/das-neue-cabaforum-tipps-test-und-hilfeseite#latest

Name= testuser Passw= testuserpass

Just type in some text and do minimum 2 spaces between two textBlocks and save it...

If you look at the latest entries of the link above, you'll see more Formating errors...

No clue what that is... i had this also in our first 2.0.18.10 Forum...

FYI: I came initially from a PHPBB3 Forum, but I don't think that has anything to do with the Bug above...

How can I correct this? It's really annoying... ;(

«13

Comments

  • your theme is lacking character encoding

    add

    <meta charset="UTF-8">

    or

    <meta http-equiv="Content-Type" content="text/html;charset=utf-8" >

    to your default.master

    grep is your friend.

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited January 2014

    yes, I tried the second one before, but that changed nothing, so I removed it...

    Now I tried your 2 proposals again, put it into the Head from default.master.tpl of my theme:

    <head> {asset name="Head"} <meta http-equiv="Content-Type" content="text/html;charset=utf-8" > respectively <meta charset="UTF-8"> </head>

    Reloaded it, put some text with space, same error...

  • x00x00 MVP
    edited January 2014

    try putting

    <meta charset="UTF-8">

    right after <head>

    grep is your friend.

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    nope.... every possible combination did not work... i also tried the +baseline Theme, wich has not any meta definition as mentioned above... i put <meta charset="UTF-8"> into Vanilla\applications\dashboard\views\default.master.tpl, but no change....
    this is really strange...
    My Theme is also based on the default "+baseline" theme...
    Tried it also with cache cleaned Firefox....

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2014

    The document type is wrong, you have html5 document type.

    stickthis in the top of the master before < head > change the lang to german

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
            <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-ca">
    

    then this after < head >

    <meta http-equiv="Content-type" content="text/html;charset=UTF-8">

    http://www.w3.org/International/questions/qa-html-encoding-declarations#quicklookup

    You can also add the following line to a .htaccess file to serve all files with a .html extension as UTF-8 in this and all child directories:

    AddType 'text/html; charset=UTF-8' html

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited January 2014

    ok, so i did:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">

    an before </head> :

    <meta http-equiv="Content-type" content="text/html;charset=UTF-8">

    the same error... ;(

    Do I have Typos? Are you sure that it is because of the Document type?
    Because I didn't change anything in this area, so it`s the same as in the default theme +Baseline....

    crazy, crazy, crazy... ;););)

    p.s. : Firebug shows the above Coding too...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Did you erase the caches?

    The charset part need to be the first thing after < head >

    Try adding that line to your htaccess file

    AddType 'text/html; charset=UTF-8' html

    I know of one other person who had this happen YAcosta about a year ago and solved it. Let me see If I can find the discussion...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok forget what I said about the doc type, is your theme bittersweet but edited ? ok

    doc type in that theme is html5

    so change that back to this with the charset

    <!DOCTYPE html>
    <html>
    <head>
    <meta charset="UTF-8">
      {asset name="Head"}
    </head>
    
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I found it , do you have this in your config.php ?

    $Configuration['Garden']['charset'] = 'utf-8';

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    ok, changed back to HTML5 doc-type, copied your code into default.master.pl

    The base of my Theme is "+baseline" (the default theme of Vanilla 2.1B2)

    still no luck...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Do you have that line in your config.php ? If not add it.

    $Configuration['Garden']['charset'] = 'utf-8';

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    just did it, no luck... AAhhhhhh.... ;(((

    is there a diffrence between

    <meta charset="UTF-8">

    and with "/"

    <meta charset="UTF-8" />

  • peregrineperegrine MVP
    edited January 2014

    try lowercasing utf-8 for grins.

    your meta on your page shows uppercase, try lower case.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    yes that depends on the doc type.

    You could go to a validator and it will tell you what errors it finds.

    http://validator.w3.org

    add your url for the forum and in the options ask for Clean up Markup with HTML-Tidy and show source so you can compare and possibly you can find what it wrong

    It is tied to not having a charset stipulated.

    peregrine
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2014

    Try writing a new post after you added the $Configuration['Garden']['charset'] = 'utf-8';

    I do not think it will affect the previous posts only the new ones after adding that line.

    Also look at the database table for comments to see if you see this in the Body etc

    Collation utf8_unicode_ci

    peregrine
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited January 2014

    ok, thanks... ;)
    After every Change I do a new post, just to be sure.. ;)
    You can see that here:
    http://www.caba.de/CaBaFoRuM/index.php?p=/discussion/2508/das-neue-cabaforum-tipps-test-und-hilfeseite#latest

    I will now try to validate and correct the Errors, I suppose that will consume some time...

    p.s.: also tested lower case... no luck...

  • peregrineperegrine MVP
    edited January 2014

    @vrijvlinder said:
    I do not think it will affect the previous posts only the new ones after adding that line.

    good point. see if adding a new comment with "special characters" is corrected in a new post.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2014

    It appears to only happen with the english language words ?

    Did you add the line in the htaccess file of your site ?

    AddType 'text/html; charset=UTF-8' html

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    no... just put some spaces between two textblocks... then the "?" appear, as in the picture above...

  • peregrineperegrine MVP
    edited January 2014

    you could look in your database and see how the characters are represented in in the body of the discussion table. to see what is coming in. Also do you see the same problem in discussion display without cleditor. and posting via buttonbar.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.