HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

No permissions?

This discussion is related to the Yet Another Gamification Application addon.

Well, I have two issues, one is that after I updated it, the buttons are different, it's showing "Yaga.Reactions" instead of "Reactions" and all the buttons having to do with Yaga are doing that. And two, I updated it because for some reason, my new admins don't have permissions to give out badges? I updated thinking it'd fix the issue, but it has given me more issues.

-Killertoad (Vanilla Version 2.1b2)

Tagged:
peregrine
«1

Comments

  • hgtonighthgtonight ∞ · New Moderator
    edited January 2014

    Thank you for trying my addon!

    The translation issue is your locale cache being out of date. Deleting /cache/locale_map.ini should fix that.

    You have to give your admin role the permission to award badges. It is called 'Yaga.Badges.Add'.

    Please remember that this is still considered beta software and issues will crop up. Thanks for reporting your issues.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    Killertoad
  • @hgtonight said:

    You have to give your admin role the permission to award badges. It is called 'Yaga.Badges.Add'.

    I have given them that, I don't think to go in depth, my past admins, before I installed yaga, can give out badges, etc. But the ones I have added after I installed Yaga can't. They all have the same permissions?

  • hgtonighthgtonight ∞ · New Moderator

    @Killertoad said:
    I have given them that, I don't think to go in depth, my past admins, before I installed yaga, can give out badges, etc. But the ones I have added after I installed Yaga can't. They all have the same permissions?

    I don't know what your role and permission set up is. You could paste all the role permissions screens here if you like.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    [Deleted User]Killertoad
  • Here it is

  • edited January 2014

    @KillerToad If you don't mind, please post a screenshot of the error you get when you try to give out badges etc. :)

    Killertoad
  • @ilovetech It literary says "You do not the the permissions to do this" If you'd like to see for yourself, I can pm you a test account's login.

  • peregrineperegrine MVP
    edited January 2014

    no problem then.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine If they can help, I don't care how old they are, no need to start something dude.

    [Deleted User]
  • edited January 2014

    @peregrine No offense, but why would you torture me based on age?

  • peregrineperegrine MVP
    edited January 2014

    @Killertoad - just trying to provide the facts dude, not trying to start anything.

    did you disable the plugin or app
    then update the plugin or app
    and then reenable it or app.

    that is the recommended way to update plugins or apps.

    if not, try disabling the app and re-enable it. That occasionally fixes mysterious problems.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Killertoad
  • @peregrine That would require me to have FTP access, which I'm sure @Killertoad won't let me have, because it gains so much access

  • edited January 2014

    @KillerToad Did you try the above for updating Yaga?

    Killertoad
  • I've tried disabling, enabled, deleting, re uploading, and even updating to the latest version, still no fix.

    peregrine[Deleted User]
  • edited January 2014

    @KillerToad Good News is, I found the problem, but sadly, not the solution at this time

    Killertoad
  • What is it?

  • That the problem is from your side (permission errors), because I have the exact same permissions for my Administrator role, and it works fine for me on Yaga 0.3.2 and last I checked, that was what @KillerToad was using

  • peregrineperegrine MVP
    edited January 2014

    @killertoad - if it were me - i would follow these instructions, dude.

    http://vanillaforums.org/discussion/comment/199091/#Comment_199091

    with the exception don't bother (re- downloading core vanilla)

    however, first (no matter how many times you did it before).
    I would however disable the plugin,
    delete the ini files in cache folder.
    delete the yaga folder from apps
    download yaga,
    reinstall and re-enable

    then re-set all yaga permissions. click and save uncheck and save. clheck and save

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • edited January 2014

    @peregrine There are some problems related to Permissions on his database. http://www.plethorastudios.com/forum/index.php?p=/utility/structure

    EDIT: Also, I did tell him to enable Debug, however, the issue he was experiencing doesn't use Debug, so that was useless. Also, @Killertoad I would agree with peregrine to what he said for your Yaga application.

    Killertoad
  • peregrineperegrine MVP
    edited January 2014

    echo echo echo..... noise echo... echo ... echo... noise.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited January 2014

    @hgtonight - WDYT?

    without the change only root admin can manually add badges.

    line 245   class.badgecontroller.php
    
    
      $this->Permission('Garden.Badges.Add');
    
    to 
    
     $this->Permission('Yaga.Badges.Add');
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightKillertoad
Sign In or Register to comment.