Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

unable to sign out

jackmaessenjackmaessen ✭✭✭
edited February 2014 in Vanilla 2.0 - 2.8

Using 2.0.18.10
I noticed that it is unable to sign out ( tested in Firefox browser) even when i deleted all the .ini files in the cache folder and after several refreshes of the browser.
Is it possible that it has something to do with my .htaccess file? Should i change something in this?

# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

# Compress .htm, .html en .less
<FilesMatch "\.(htm|html|less)$">
  SetOutputFilter DEFLATE
</FilesMatch>


# Cache
<filesMatch ".(ico|pdf|flv)$">
    Header set Cache-Control "max-age=29030400, public"
</filesMatch>

<filesMatch ".(jpg|jpeg|png|gif|swf|css|js|eot|svg|ttf|woff)$">
    Header set Cache-Control "max-age=604800, public"
</filesMatch>

<filesMatch ".(html|htm|php)$">
    Header set Cache-Control "max-age=172800, public"
</filesMatch>


<IfModule mod_headers.c>
  <FilesMatch "\.(js|css|xml|gz)$">
    Header append Vary: Accept-Encoding
  </FilesMatch>
</IfModule>

<ifModule mod_headers.c>
    Header set Connection keep-alive
</ifModule>


# Expiration  headers
<IfModule mod_expires.c>
# Enable expirations
ExpiresActive On
# Default directive
ExpiresDefault "access plus 1 month"
# My favicon
ExpiresByType image/x-icon "access plus 1 year"
# Images
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType image/jpg "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
# CSS
#ExpiresByType text/css "access 1 month"
# Javascript
ExpiresByType application/javascript "access plus 1 year"
</IfModule>
Tagged:

Comments

  • Options
    hgtonighthgtonight ∞ · New Moderator

    What do you mean by unable to sign out?

    Is there no sign out link?

    Does clicking the link not do anything?

    Does clicking the link direct you to another page but you remain logged in?

    Are you using any type on connection plugins?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    jackmaessenjackmaessen ✭✭✭
    edited February 2014

    Of course there is a signout link, and when clicking on it, it redirects to discussions page; but the name of the user still keeps alive on the screen, and he is not really signed out because you can post a new discussion; so the login session keeps alive. When i empty the browser cache, then you can sign out.
    I am not using any kind of connection plugins.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Sessions data is stored in cookies.

    Try it on a few more browsers to see if it is a browser issue.

    Are you using any type of connection plugins?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    This is really strange. In Chrome and IE you can sign out without problem. So it looks like this problem only appears in Firefox.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    This is most likely an issue with a plugin you have enabled in FF. Try disabling your plugins one by one until you find out which one caused the issue.

    Please report back so others may know.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    well, i disabled all the plugins of FF but it didn't change anything. But i figured out that when i uncomment all the lines of my .htaccess except the compression, FF also signs out. So there is a problem with the cache, the cookie is not deleted when you sign out. But this problem is only in FF. I tested in Chrome, IE, Opera en Safari and all of them signed me out.

  • Options
    peregrineperegrine MVP
    edited February 2014

    what happens if you start with original and remove only

    # Default directive
    ExpiresDefault "access plus 1 month"
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    jackmaessenjackmaessen ✭✭✭
    edited February 2014

    i figured something out: it is not only 1 line, it seems to be 2 lines who are responsible for the behaviour of FF.
    I disabled these 2 lines:

    <filesMatch ".(html|htm|php)$">
        #Header set Cache-Control "max-age=172800, public"    disabled
    </filesMatch>
    
    # Javascript
    #ExpiresByType application/javascript "access plus 1 year"    disabled
    

    Now i can singout with FF. But i still do not understand that this only happens in FF and not in the other browsers...

    EDIT:
    I tested again and i now have the same problem; can not sign out.
    One of the members of the forum told me that sometimes he could sing out on FF, and sometimes not. This is really strange...

  • Options
    hgtonighthgtonight ∞ · New Moderator

    The browser interprets headers however they want.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    <filesMatch ".(html|htm|php)$">
        #Header set Cache-Control "max-age=172800, public"      disabled
    </filesMatch>
    
    # Default directive
    #ExpiresDefault "access plus 1 month"       disabled
    
    # Javascript
    #ExpiresByType application/javascript "access plus 1 year"       disabled
    

    This seems to work! I tried several times login and logout on FF and now every time he logs me out.
    So it is a combination of lines that should be disabled for FF.

Sign In or Register to comment.