Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Is there an easy way to remove the ACTIVITY menu for everyone but the ADMIN?

Says it all

Comments

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Remove all activity permissions for all roles.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    except admin role.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @peregrine said:
    except admin role.

    Removing it from admin role will still keep it available to the original admin (super admin I would call it).

    But yes, you should keep the permissions for the admin roles in general.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    The first thing I tried was changing the roles but that still leaves the menu item in place.
    You just get permission denied when you click on it.

    I want the word "Activity" gone from the menu.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2014

    just remove the link or add permissions to it . then add one with permissions you want

    then it will only appear to admin

    $this->Menu->AddLink('Activity', T('Activity'), '/activity',array('Garden.Settings.manage'));
    $this->Menu->RemoveLink('Activity', T('Activity'), '/activity');
    
  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    If you have 2.1 and the activity link appears in the filter menu use css

    #Panel .FilterMenu li.Activities {
    display: none;
    }
    
Sign In or Register to comment.