Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Trying to get Awards Plugin to Work - Maybe Problem with Logger Plugin?

The Awards Plugin looks great, and I have tried to follow the readmes.

I have installed Aelia Foundation Classes and Logger as required.

But there seems to be a problem with Logger, when I hit Settings, I get the Permission Problems Error message. I didn't think there were any settings for that plugin, the readme suggests it should work out of the box.

I have them all enabled, but still get an error when I select the Awards Plugin Settings (Permission Problems).

the readme says that several directories must be writable. They are writable by Owner in FTP (755), is that sufficient?

anything else I might be doing wrong?

Thanks in advance, and apologies if this topic has been covered. Search is down as the board is being fixed.




  • Options
    hgtonighthgtonight ∞ · New Moderator

    The best thing you can do is post under the plugin you are having issues with so it pings the author.

    I got your back this time ;)

    @businessdad, be notified of this issue.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Do the error messages say which permissions in particular are causing the problem? Do those permissions exist in the roles and permission settings that you can give to the admin role?

    The 755 directory permission level is sufficient if your web server is executing PHP as a group user. 777 is only needed if the web server requires full permissions to write and execute files.

    Add Pages to Vanilla with the Basic Pages app

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    I fixed Dave's issue. Seems that he had not set permissions for admin to access the settings for the plugin. :)

  • Options
    businessdadbusinessdad Stealth contributor MVP

    @vrijvlinder said:
    I fixed Dave's issue. Seems that he had not set permissions for admin to access the settings for the plugin. :)

    Thanks for taking care of it. I'm extremely busy these days, with the "addon" of a plethora of bad news to handle. Every time I want to reply to someone on the forum, something kicks in and I get sidetracked.

    Good job! :)

  • Options

    Thanks so much @vrijvlinder for the personal help and @businessdad for the great plugin!

    This is such a great community here. I hope to learn enough to contribute!

  • Options

    @davematson Also, while the search is down, use Google and search: " term". Common sense would tell you by the way to replace term with the search term.

Sign In or Register to comment.