Please upgrade here. These earlier versions are no longer being updated and have security issues.

Fatal Error in Gdn_Autoloader.RegisterMap();

Hello,

Not certain I understand the extent of this issue and was hoping someone could give some advice.

I've migrated from a database another installation that was using the alpha installation of Vanilla 2.2 I believe.

Everything imported into the stable version of Vanilla 2.0.18.10 perfect.

Stupid decision on my part to use a alpha installation on a live website but really liked that responsive theme!

Anyways, created a custom theme, tested out OK after the import (members, passwords, posts, etc., all good).

Now I go and try to edit the "Roles & Permissions" and I get a "Bonk" error.

Enabling the debug, I was able to get these results (attached as two screenshots):

Any thoughts on this would be fantastic as I currently have this on a live website. Thanks anyone who can offer advice.

Comments

  • The Image attachments didn't work with the previous URLs so here they are:

    https://www.dropbox.com/s/z51h2zcwwghrpbq/debug-1.png

    https://www.dropbox.com/s/zr9j6z1jghpg0nl/debug-2.png

  • Found my own solution by replacing the following tables from a clean installation of Vanilla 2.0.18.10

    GDN_Permission

    GDN_Role

    Once those tables were dropped and replaced with the originals I was able to clear the "Bonk" error shown.

    Hope it helps someone else.

    R_Jhgtonight
  • hgtonighthgtonight ∞ · New Moderator

    This type of error is due to running PHP 5.5, iirc. The autoloader uses a deprecated function which raises a warning.

    In debug mode, this warning is shown. Disabling debug mode should have cleared this issue as well.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Hello,

    I am not running PHP 5.5 on this server. Currently running 5.4.

    The error was displayed "prior" to debug being enabled. I did that to see the issue.

    No worries though, as explained above I was able to resolve this.

    Thanks for your insight.

    hgtonight
Sign In or Register to comment.