Please upgrade here. These earlier versions are no longer being updated and have security issues.

URLs to my forum suddenly not working

On my WP site my vanilla forum is on its own separate url. Lately I noticed some strange problems related to the two URLS. It goes like this: #1 Visitor clicks on mysite.com and then decides to click on mysite.com/forum and is redirected back to the home page of mysite.com The visitor can not enter the form from mysite.com. I assumed this was a blocker coming from Firefox not allowing users to leave my website and enter an unknown URL. How do I get around this? I'm losing traffic.

Issue # 2 I created a campaign running on several social media sites to boost traffic to the forum and when I looked at the campaign performance in hubspot I was alerted to the fact that my forum URL is giving an error. Users can not click over to mysite.com/forum. The urls were working fine when I tested them. Has anyone heard of this happening? What do I do?

Comments

  • sounds like your .htaccess may have a problem

    or do you have other redirection set up.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    IIRC, you have the auto-sign in plugin running with SSO. Clicking on the forum link should force you to sign in through your WP site.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    Shadowdare
  • K17K17 Unkorneglosk - Français / French Paris, France ✭✭✭

    mod_rewrite is active? Apache can disable it. (this is an apache error)

  • x00x00 MVP
    edited March 2014

    @hgtonight said:
    IIRC, you have the auto-sign in plugin running with SSO. Clicking on the forum link should force you to sign in through your WP site.

    Doesn't work this way, it doesn't stop people browsing the forum.

    @‌jens1seo more like your servers rules are surping vanilla, and it is redirecting to your main site.

    All pure speculation with no examples.

    grep is your friend.

  • hgtonighthgtonight ∞ · New Moderator

    @x00 said:
    Doesn't work this way, it doesn't stop people browsing the forum.

    Thanks for the clarification. This is what happens when @hgtonight makes assumptions. :D

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Hey guys sorry for the late replay on this one. Here is the url I captured on the fly that seems to be directing all traffic back to my home page
    http://2moveabroad.com/expat-forum/index.php?p=/entry/jsconnect&client_id=447201574&Target=/
    I have no idea whats going on. I basically lost all traffic this past month and I'm getting to the point where I might have to consider another forum. It seems like one problem after another. Sigh:(

  • PS I do not have an auto sign that I know of just standard WP sign in

Sign In or Register to comment.