Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Exception-Popup Code 256

Hello everyone!

I just installed 2.1rc1 (before I was testing stable version 2.0 - I sometimes get the same error)

I'm getting the following error:

{"Code":256,"Exception":"Incorrect integer value: '' for column 'CategoryID' at row 1|Gdn_Database|Query|insert GDN_Draft \n(`Body`, `CategoryID`, `InsertUserID`, `UpdateUserID`, `Name`, `Tags`, `Announce`, `Format`, `DateInserted`, `DateUpdated`) \nvalues (:Body, :CategoryID, :InsertUserID, :UpdateUserID, :Name, :Tags, :Announce, :Format, :DateInserted, :DateUpdated)","Class":"Gdn_ErrorException"}

It appears when I'm writing a new discussion and I think it has to do with the automated Draft system. I'm running PHP 5.4 and I often get some errors.

Can anyone help? :)


  • Options
    lumiolumio New
    edited April 2014

    Okay, I just found out that the problem is the Tagging Addon.

    As soon as you enabled the Tagging Addon, the error appears as soon as the automatic draft is saved (or as soon as you click save draft).

    Disabling won't help: You still get this error.

    //edit: Okay Tagging alone is not the problem. Even other modules can cause this problem.
    //edit2: Against my first post: The stable version is not affected.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    I've tried that on a test db:

    INSERT INTO `V21b2_Draft` (
    `DraftID` ,
    `DiscussionID` ,
    `CategoryID` ,
    `InsertUserID` ,
    `UpdateUserID` ,
    `Name` ,
    `Tags` ,
    `Closed` ,
    `Announce` ,
    `Sink` ,
    `Body` ,
    `Format` ,
    `DateInserted` ,
    VALUES (
    NULL , '1', '' , '1', '1', 'test', NULL , '0', '0', '0', 'test', NULL , '', NULL

    ... and it's working although I've inserted '' into column CategoryID. So maybe your database is running in strict mode?

  • Options
    lumiolumio New
    edited April 2014

    So maybe your database is running in strict mode?

    Yes it does - but wouldn't it be better to respect that?
    Otherwise: How to change that?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    As far as I know, Vanilla is not supporting strict mode officially, but @Chanh is very busy getting Vanilla to work with it. Maybe he can give you an advice (if simply turning off strict mode is no option for you)

  • Options

    Okay, I'm checking how to turn it off. Let's see :)

  • Options
    chanhchanh - CMS Researcher ✭✭

    Which exactly the add-on that you are using?
    I will take a look when I have time.

  • Options

    @chanh: It's almost every plugin. But especially it's the Tagging plugin.

  • Options
    chanhchanh - CMS Researcher ✭✭

    which one? tag cloud or tagging enhanced?

  • Options
    LincLinc Detroit Admin

    @chanh 'Tagging' is a core addon.

  • Options
    FerrariSteveFerrariSteve Seattle
    edited July 2014

    Confirmed. Disabling Strict Mode fixed this for me.

    This is in my default my.cnf file:

    # Recommended in standard MySQL setup

    I commented that line out and set sql_mode without the strict option:

    # Recommended in standard MySQL setup

    Now I don't get the red popup when trying to edit a member.

Sign In or Register to comment.