Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Cant add any more than the standard three

JanHoosJanHoos
edited May 2014 in Vanilla 2.0 - 2.8

Hi guys!

I've just installed this plugin. I've got it to work with the standard 3 sentences/replies, but as soon as I add one to botreplies, config, save & upload it won't work.

When I modify an example one it works, but adding a new one will not work :(

botreplies addition: 
function BotWapen($Bot) {
   if ($Bot->SimpleMatch('wapen'))
      return $Bot->Mention().' Wapen hebben we hier niet!';
}

this goes in my config file:

 //BOT
 $Configuration['Plugins']['ShwaipBot']['ReplyOrder'] = array('BotShave', 'BotWapen', 'BotMuffinMan', 'BotSendBeer');

What am I missing. Running 2.1 Vanilla. Tried clearing caches.

Comments

  • Options
    peregrineperegrine MVP
    edited May 2014

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    LincLinc Detroit Admin

    Did you make sure there isn't another $Configuration['Plugins']['ShwaipBot']['ReplyOrder'] in your config.php already?

  • Options

    @peregrine‌ Refreshing as in CMD R? Yes :) Did not work. Also tried emptying the cache of Vanilla.

    @Linc‌ I was under the impression there wasnt a standard one in the config already, only the one I've added. So I did not check. If there is only the one I've added, than no. Just the one I've added and modified. I'll try again later :)

    Thanks for your answers :)

  • Options

    Somehow it ended up working on the server where I wanted to deploy the forum. I had to reupload the config file and redo the chmod everytime.

    The shwaip bot turned off everytime I uploaded a new version. When I re-enabled it, it worked :) So now I've got a few extra added and am thinking of some more.

Sign In or Register to comment.