Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Some users don't have the invite text-field on 2.1

So using 2.1 on my forum, with registration set to invite some users seem to have the text-field to enter an e-mail, while others do not. I have checked their member status and looked at the users but have found no difference. So far I have been unable to find a pattern between the users that have the field and those that don't.

Does anyone here have any ideas? Maybe even fixed the issue themselves?!

«13

Comments

  • role?

    grep is your friend.

  • mnerurkarmnerurkar New
    edited May 2014

    They are all in the "Member" and "Not Verified" roles.

  • why are they not verified? i think you need to tweak your default roles.

    grep is your friend.

  • mnerurkarmnerurkar New
    edited May 2014

    No, I don't think so. Also as far as I see the verification thing is a manual setting - it's not in the roles. It's something new in v2.1 where you can manually verify users to ignore spam and pre-moderation settings.

    Regardless, this doesn't seem to be the issue because all members are non-verified, yet some have the text box and some dont

  • hgtonighthgtonight ∞ · New Moderator

    @x00 I believe he is referring to their spam verification status. It is listed as a role on the profile but is actually a property of the user.

    @mnerurkar‌ verify your member role is in the Garden.Registration.InviteRoles config item.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • mnerurkarmnerurkar New
    edited May 2014

    Hm. The issue is that members from within the same role sometimes have the field, and sometimes don't.

    Regardless:

    $Configuration['Garden']['Registration']['InviteRoles'] = 'FALSE';

  • hgtonighthgtonight ∞ · New Moderator

    You need to set up the invitation amounts in the Registration section in the dashboard.

    https://forums.example.com/dashboard/settings/registration

    When the registration mode is set to invitation, you should see some dropdowns letting you give each role a number of invites per month.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • That was done, which can be seen in the fact that some users of the Membrr Role do hsave a invitation textfield...

  • I've went through the Database looking at the users I know which have the field and those which have reported not having it. It seems as if "Show email" is the only thing that is different for these two groups: All who had the field had it set to 0, all who didn't have the field had it set to 1. So this is not neccessarily a correllation yet - I've asked the users to change their settings and we'll see if that's the culprit.

  • Alright... it doesn't seem to be the cause.

  • Anyone have any other ideas?

  • hgtonighthgtonight ∞ · New Moderator

    @mnerurkar‌ If that config item is still false after assigning a number of invites, that is your issue.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Which config file?
    $Configuration['Garden']['Registration']['InviteRoles'] = 'FALSE';

    What should it read instead?

  • hgtonighthgtonight ∞ · New Moderator

    /conf/config.php is the only config file you should be editing. It should list a serialized array of the role numbers that get to dole out invites.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDog
  • peregrineperegrine MVP
    edited June 2014

    set it in your dashboard.

    an e.g. of how it might look (not necessarily how you want it. I think this is the old style.
    $Configuration['Garden']['Registration']['InviteRoles'] = 'a:5:{i:3;s:1:"0";i:4;s:1:"0";i:8;s:1:"0";i:32;s:1:"0";i:16;s:1:"0";}';

    or posssibly

    I set it via the dashboard and this is what I get in vanilla 2.1

        $Configuration['Garden']['Registration']['InviteRoles']['3'] = '1';
        $Configuration['Garden']['Registration']['InviteRoles']['4'] = '1';
        $Configuration['Garden']['Registration']['InviteRoles']['8'] = '1';
        $Configuration['Garden']['Registration']['InviteRoles']['16'] = '1';
        $Configuration['Garden']['Registration']['InviteRoles']['32'] = '1';
    

    the number in brackets is the role id.
    the number to the right is the number of invitations.

    $Configuration['Garden']['Registration']['InviteExpiration'] = '-2 weeks';

    this means expirations expire in 2 weeks.

    this means your registration is set to invite

    $Configuration['Garden']['Registration']['Method'] = 'Invitation';

    but modifying via the dashboard should set things properly.

    here is a screenshot of what you should see, select the dropdowns and modify as you need.

    you might also run /utility/structure and utility/update to see if they help.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightUnderDogvrijvlinder
  • mnerurkarmnerurkar New
    edited June 2014

    Well I have set everything in the dashboard. And the system had worked before the 2.1 update.
    I will double check this and see if I maybe looked at the wrong config file or something.

    Thanks everyone :)

  • hgtonighthgtonight ∞ · New Moderator

    If this doesn't work, we will have to do some more digging.

    I look forward to your reply!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Well I have set everything in the dashboard. And the system had worked before the 2.1 update.

    maybe you need to reset it again, to take effect.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • So, I double checked.

    in my forum/conf/config.php I have:

    $Configuration['Garden']['Registration']['InviteRoles'] = 'a:5:{i:3;s:1:"0";i:4;s:1:"0";i:8;s:1:"1";i:16;s:2:"-1";i:32;s:1:"1";}';

    So old style. I'll do some experimenting...

  • Alright: I changed the settings and this is the new config style, as you mentioned @peregrine‌

    $Configuration['Garden']['Registration']['InviteRoles']['3'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['8'] = '1';
    $Configuration['Garden']['Registration']['InviteRoles']['16'] = '-1';
    $Configuration['Garden']['Registration']['InviteRoles']['32'] = '2';

    I'll see if that fixes things

Sign In or Register to comment.