Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Version Number

Hello. I think I've found something weird. I am using the Vanilla 2.1 Stable, and when I check the version number in the Dashboard, it says 2.2.12. Is this a bug? Thank you!

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    The admin dashboard echos the defined 'APPLICATION_VERSION' in the footer. This is defined in your index.php file.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    So what should it be? 2.1?

  • Options
    hgtonighthgtonight ∞ · New MVP

    It is defined as 2.1 in the currently available zip file download.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    peregrineperegrine MVP
    edited June 2014

    So what should it be? 2.1?

    this is a somewhat silly question. if you downloaded the 2.1 source and copied all the files correctly.
    it will reflect what it should be.

    vanilla 2.1 zip is found here: http://vanillaforums.org/addon/vanilla-core-2.1

    the bug is because you didn't properly copy all of the files necessary for installation to your forum.

    who knows what other files you left out.

    re-install the 2.1 source to be correct.

    modifying and picking and choosing core files, is not a great idea as you found out, and ensuring that you do a proper install with all files copied is another good tip.

    this discussion should be closed. re-copy all files from the 2.1 downloaded zip, and be done with it.

    then after you copy over all 2.1 files to your installation properly and it says.2.1 in your dashboard.

    http://vanillaforums.org/discussion/26943/tutorial-how-to-determine-the-version-number-of-vanilla-that-you-are-using-for-your-own-forum

    • then you can modify your config.php to reflect 2.1 (so you don't get confused later, since the config.php version numbers aren't used by vanilla and are not updated on an update), but could be used by a plugin, if someone wrote a plugin to pull version number out of config.php (which they shouldn't have done).

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.