Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Tried a lot still cant enable Login with Google

I know i do have one more thread regarding the same issue, any one here know why this is happening to vanila 2.1 , Cant enable authentication methods otherthan password. Any help highly appreciated @hgtonight please excuse

«1

Comments

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Enable OpenID. Enable Google sign in.

    What errors are you getting?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Tried this . first I enable d openid and then Google sign in . and after from authentication tried yo enable both apart from password. A prodressbar appeared infinitely and nothing else happened.once when debugger enabled got a message to re index theme and plugin cache

  • Options
    ransimransim New
    edited June 2014

    I'm having a similar issue as well, fresh install of 2.1 on my server and I can't seem to be able to set Google or OpenID as the authentication method. If you select either as @abhilashsnair mentioned the progress bar animation appears but nothing happens.

    Checking console in the browser and I can see its throwing a 404.

     Failed to load resource: the server responded with a status of 404 (Not Found) 
     http://forum.arclightcomics.com/v/dashboard/plugin/googlesignin?DeliveryType=VIEW
    
     Failed to load resource: the server responded with a status of 404 (Not Found) 
     http://forum.arclightcomics.com/v/dashboard/plugin/openid?DeliveryType=VIEW
    

    config.php has not been altered. OpenID was enabled first and then Google Sign In.

    As far as I can tell the plugin code is there, this is happening in both chrome and firefox, including when plugins are disabled.

    I've also tried adding mod_speling to my server and enabling it for the site in case it was an issue with case sensitivity, I did notice some of the folders were installed with camel case names. That also did not resolve the 404 error.

    PHP Info for the server for reference: http://forum.arclightcomics.com/v/phpinfo.php

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    404 error is something different. Please look at the tutorial about 404 error....

    http://vanillaforums.org/discussion/25111/about-error-404-not-found

  • Options
    peregrineperegrine MVP
    edited June 2014

    are you using apache or nginx. Are your .htaccess rules ok, if using apache.

    looks like apache :)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    ransimransim New
    edited June 2014

    My .htaccess file is set up properly, so far everything else is working properly:

    # Modified - 18/06/2014
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /v
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    
    <IfModule mod_speling.c>
      CheckCaseOnly On
      CheckSpelling On
    </IfModule>
    

    This 404 is ONLY happening when Google or OpenID is selected in the dropdown from the Authentication page on the dashboard. It is happening during and ajax call to load, I assume, either a popup or the settings/config for Google Sign in or OpenID.

    Also in case it is helpful here is my config.php

    <?php if (!defined('APPLICATION')) exit();
    
    // Conversations
    $Configuration['Conversations']['Version'] = '2.1';
    
    // Database
    $Configuration['Database']['Name'] = '###';
    $Configuration['Database']['Host'] = '###';
    $Configuration['Database']['User'] = '###';
    $Configuration['Database']['Password'] = '###';
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['GettingStarted'] = 'GettingStarted';
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    $Configuration['EnabledPlugins']['OpenID'] = TRUE;
    $Configuration['EnabledPlugins']['GoogleSignIn'] = TRUE;
    
    // Garden
    $Configuration['Garden']['Title'] = '###';
    $Configuration['Garden']['Cookie']['Salt'] = '###';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = '1';
    $Configuration['Garden']['Registration']['Method'] = 'Approval';
    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '3';
    $Configuration['Garden']['Registration']['CaptchaPrivateKey'] = '';
    $Configuration['Garden']['Registration']['CaptchaPublicKey'] = '';
    $Configuration['Garden']['Registration']['InviteExpiration'] = '-1 week';
    $Configuration['Garden']['Registration']['InviteRoles']['3'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['8'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['16'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['32'] = '0';
    $Configuration['Garden']['Email']['SupportName'] = 'Arclight';
    $Configuration['Garden']['InputFormatter'] = 'Html';
    $Configuration['Garden']['Version'] = '2.1';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['Cdns']['Disable'] = FALSE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['SystemUserID'] = '2';
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['InstallationID'] = 'DC38-ECD89F9D-B3BEAF77';
    $Configuration['Garden']['InstallationSecret'] = '###';
    
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    $Configuration['Plugins']['GettingStarted']['Plugins'] = '1';
    $Configuration['Plugins']['GettingStarted']['Registration'] = '1';
    
    // Routes
    $Configuration['Routes']['DefaultController'] = 'discussions';
    
    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.1';
    
    // Last edited by admin (72.66.104.78)2014-06-18 23:25:14
    
  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2014

    mis spelled url? try this

    // add a filter to redirect the correct uri:
    if (requestURI.startsWith("/_ah/api/_ah/api")) {
      ((HttpServletResponse)res).sendRedirect(requestURI.substring(8));
      return;
    }
    

    http://code.google.com/p/google-api-javascript-client/issues/detail?id=147

  • Options
    peregrineperegrine MVP
    edited June 2014

    maybe hgtonight has an idea since you are actually providing useful detailed information to help sort things out.

    just wild guesses change to

    $Configuration['Garden']['RewriteUrls'] = FALSE;

    don't know if you mod security stuff has anything to do with things or the eaccellerator.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    ransimransim New
    edited June 2014

    @peregrine - Disabling rewrite still produces the same error:

    Failed to load resource: the server responded with a status of 404 (Not Found)
    http://forum.arclightcomics.com/v/index.php?p=/dashboard/plugin/googlesignin&DeliveryType=VIEW
    

    @vrijvlinder

    Where would that filter go? Sorry I'm brand new to Vanilla so apologies on that front. Also reading the notes in the thread you linked it seems to indicate that it was resolved overall so the filter shouldn't be necessary.

    A bit more information, it seems that even trying to register as a google user is throwing a 400 error and has a note about deprecation of OpenID on Google's end:

    1. That’s an error.

    OpenID auth request contains an unregistered domain: http://forum.arclightcomics.com

    Learn more

    That’s all we know.

    It appears that Google disabled new registrations as OpenID clients back in May. Not sure if this is related.

  • Options

    I kind of recall something related to that discussed in this forum, I don't use either plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    So it seems like this is definitely the issue. It appears someone started a GooglePlus Addon to replace the older ones but it doesn't appear to be complete:

    https://github.com/vanilla/vanilla/issues/1891

    I was able to download it from Git and add it, enable it, and put in the client ID and secret, but it doesn't appear to actually add it to the auth list or enable it as a login/registration option.

  • Options

    Any plugin to make Google sign in. Tried login radius. But s not a standalone one . need subscription to their services.earlier before 2.1 everything was in place and I was using for more than one site . now no hope.

  • Options

    on the way is there any option to bring Login with Facebook atleast

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    @hgtonight I tried that plugin without luck, I got some errors in debug/trace but I ran out of time last night. Here is where I got too:

    Google Plus Settings (keys obfuscated):

    Registration Setting:

    Authentication does not have GooglePlus as an option:

    Going then to the Register page in a separate browser I get this:

    Whoops!
    Page not found.
    
    Error
    404 Not Found
    Trace
    #0 /home/arclight/public_html/v/applications/dashboard/controllers/class.entrycontroller.php(1254): NotFoundException()
    #1 /home/arclight/public_html/v/applications/dashboard/controllers/class.entrycontroller.php(1106): EntryController->RegisterConnect('')
    #2 [internal function]: EntryController->Register('')
    #3 /home/arclight/public_html/v/library/core/class.dispatcher.php(350): call_user_func_array(Array, Array)
    #4 /home/arclight/public_html/v/index.php(46): Gdn_Dispatcher->Dispatch()
    #5 {main}
    

    If I set Registration back to Invitation or any other option it works as expected.

  • Options
    AdrianAdrian Wandering Spirit Montreal MVP

    Google's support for OpenID has been deprecated. Existing accounts already connected work, new accounts trying to make the connection will not. ( As for May 19th 2014): https://developers.google.com/+/api/auth-migration#timetable

    Google+ is being worked on, but we need to account for backward compatibility.

    Hope that helps

  • Options

    @Adrian said:
    Google's support for OpenID has been deprecated. Existing accounts already connected work, new accounts trying to make the connection will not. ( As for May 19th 2014): https://developers.google.com/+/api/auth-migration#timetable

    Google+ is being worked on, but we need to account for backward compatibility.

    Hope that helps

    Thanks for the update. I've moved forward with using Vanilla without the SSO to google for now and if I get some time in the next couple weeks I might try to tackle helping with the G+ plugin myself.

  • Options
    cbunting99cbunting99 Texas New

    It's kind of ashame.. I was using UseResponce but then replaced it to just us a thread in Vanilla for feature requests on our site.. UR allows you to sign in with FB, Google, Twitter ETC and you don't have to do anything other than turn the feature on. It doesn't require api keys or even going to any social sites to use it.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @cbunting99 It is simply not possible to securely authenticate against a 3rd party without having a client key. I just downloaded the Use Response system to look into your claim. It requires a Twitter App ID and Twitter App Secret to log in via Twitter. Likewise, Facebook requires an App ID and Secret Key and Google requires a Consumer Key and Consumer Secret.

    I am assuming you tried out their hosting package and they supplied the keys in a seamless experience. That is the only way I can think of getting by without the required keys.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    cbunting99cbunting99 Texas New

    I used the hosted version.. Actually, I think when I had set it up, you supplied the email and password for the twitter and facebook account, but I never created any keys until I tried with Vanillia.. facebook works for me, but twitter gives an ssl error (SSL is required) if the user is not logged in yet. So you can't login with twitter, but once you login via regular login, you can tweet a post from twitter.

    I'm still new to Vanilla, could just be myself doing something wrong.

Sign In or Register to comment.